Closed Bug 463810 Opened 11 years ago Closed 11 years ago

Add ellipsis to "Clear Recent History" button in about:privatebrowsing

Categories

(Firefox :: Private Browsing, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED
Firefox 3.1b3

People

(Reporter: u60234, Assigned: ehsan)

References

Details

(Keywords: late-l10n, polish, verified1.9.1)

Attachments

(1 file, 4 obsolete files)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081108 Minefield/3.1b2pre

Shouldn't there be an ellipsis in the "Clear Recent History" button label in about:privatebrowsing? No history is cleared without further input from the user, and the Tools -> Clear Recent History… menuitem that opens the same window has an ellipsis.

Steps to reproduce:
1. Enter Private Browsing mode via Tools -> Private Browsing
2. Fear immediate loss of your history if you touch the "Clear Recent History" button.
CCing faaborg for input.  Alex, do we want an ellipsis for the "Start Private Browsing" button in bug 463400 as well?
>Shouldn't there be an ellipsis in the "Clear Recent History" button label in
>about:privatebrowsing?

Yep, I messed that up in the mockup, sorry about that.

>Alex, do we want an ellipsis for the "Start Private
>Browsing" button in bug 463400 as well?

The menu command doesn't have it.  In this case if the user has checked the prompt not to appear, the action will be immediate.  In general the ellipses implies more input will be required, so I would say probably no.  For instance, File > Exit doesn't have an ellipsis even though it produces a dialog box asking if you want to save your session.
Attached patch Patch (v1) (obsolete) — Splinter Review
Assignee: nobody → ehsan.akhgari
Status: NEW → ASSIGNED
Attachment #347636 - Flags: review?(beltzner)
Comment on attachment 347636 [details] [diff] [review]
Patch (v1)

No risk, nice to take for beta 2.
Attachment #347636 - Flags: approval1.9.1b2?
Attached patch UTF-8 patch, fwiw (obsolete) — Splinter Review
Attachment #347636 - Attachment is obsolete: true
Attachment #347638 - Flags: review?(beltzner)
Attachment #347638 - Flags: approval1.9.1b2?
Attachment #347636 - Flags: review?(beltzner)
Attachment #347636 - Flags: approval1.9.1b2?
Keywords: polish
Attachment #347638 - Flags: review?(beltzner)
Attachment #347638 - Flags: review+
Attachment #347638 - Flags: approval1.9.1b2?
Attachment #347638 - Flags: approval1.9.1b2-
Comment on attachment 347638 [details] [diff] [review]
UTF-8 patch, fwiw

r+ but a- as this is latel10n we can't take it for b2
Keywords: late-l10n
If you want all 60 locales to catch this, you need to change entity's name.
Attached patch For checkin (obsolete) — Splinter Review
(In reply to comment #7)
> If you want all 60 locales to catch this, you need to change entity's name.

Done.
Attachment #347638 - Attachment is obsolete: true
Attached patch For checkin (obsolete) — Splinter Review
The previous patch was missing the changes to aboutPrivateBrowsing.xhtml...
Attachment #348016 - Attachment is obsolete: true
Comment on attachment 348088 [details] [diff] [review]
For checkin

a191=beltzner
Attachment #348088 - Flags: approval1.9.1+
Attachment #348088 - Attachment is obsolete: true
Please make sure you qrefresh with -U in the future.  I almost pushed this as me because there was no username stored in the patchfile.

http://hg.mozilla.org/mozilla-central/rev/9bf88e2ecc45
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b3
(In reply to comment #12)
> Please make sure you qrefresh with -U in the future.  I almost pushed this as
> me because there was no username stored in the patchfile.

Sorry for the inconvenience.  Didn't know this.  I noted this in the MeteredCheckins page.
Blocks: 469158
Looks good using ozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081216 Shiretoko/3.1b3pre. Will verify on Mac and Linux next.
Mass moving of all Firefox::General private browsing bugs to Firefox::Private Browsing.
Component: General → Private Browsing
QA Contact: general → private.browsing
Verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081222 Shiretoko/3.1b3pre as well as on Intel Tiger Mac.

Also looks fine on the trunk using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20081222 Minefield/3.2a1pre
Status: RESOLVED → VERIFIED
This landed pre-branching, so fixed1.9.1:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/9bf88e2ecc45
(was showing up in my queries of late-l10n bugs needing checkin)
Keywords: fixed1.9.1
verified FIXED on Shiretoko: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090513 Shiretoko/3.5b5pre ID:20090513030639
You need to log in before you can comment on or make changes to this bug.