Port |Bug 211439 - Delete should mark as read (also on POP and IMAP when offline)| to SeaMonkey

RESOLVED FIXED in seamonkey2.0a2

Status

SeaMonkey
MailNews: Message Display
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.0a2

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081108 SeaMonkey/2.0a2pre

TB bug 211439 made it so that messages always get marked read when deleted (from POP accounts or local folders; IMAP seems to be handled elsewhere already). I think SM should do the same.

Reproducible: Always
(Assignee)

Updated

9 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

9 years ago
Created attachment 347102 [details] [diff] [review]
Port from Bug 211439
Attachment #347102 - Flags: review?(mnyromyr)

Updated

9 years ago
Assignee: nobody → jh
Status: UNCONFIRMED → NEW
Component: MailNews: Backend → MailNews: Message Display
Ever confirmed: true
QA Contact: mailnews-backend → message-display

Comment 2

9 years ago
Comment on attachment 347102 [details] [diff] [review]
Port from Bug 211439

I tend to agree, from personal experience ("How did that unread message go into the trash? Oh, hm, I really deleted it...").
Attachment #347102 - Flags: superreview?(neil)
Attachment #347102 - Flags: review?(mnyromyr)
Attachment #347102 - Flags: review+

Comment 3

9 years ago
(In reply to comment #0)
> IMAP seems to be handled elsewhere already
Out of interest, is that just IMAP delete model or move to trash too?
(Also, would be interesting to know if it works with filters or not.)

Comment 4

9 years ago
Comment on attachment 347102 [details] [diff] [review]
Port from Bug 211439

The old code was bogus anyway because if you were context-deleting a message then the wrong one would get marked as read.
Attachment #347102 - Flags: superreview?(neil) → superreview+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed

Comment 5

9 years ago
Landed on Hg trunk as <http://hg.mozilla.org/comm-central/rev/0f29f61153ba>.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0a2
You need to log in before you can comment on or make changes to this bug.