Closed Bug 463879 Opened 11 years ago Closed 11 years ago

TM: Doesn't build on ARM

Categories

(Core :: JavaScript Engine, defect, blocker)

x86
Maemo
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: pavlov, Assigned: vlad)

References

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Mobile/1226162372.1226162656.31652.gz&fulltext=1

looks to have been broken by  http://hg.mozilla.org/mozilla-central/rev/863f06764089 

some of the fixes are just s/savedParams/savedRegs/, but the merging of branchAdjust and branch I don't quite follow nor the far jump stuff.
Duplicate of this bug: 463883
I have this mostly fixed; patch coming up soon.
Assignee: general → vladimir
Pushed:

http://hg.mozilla.org/tracemonkey/rev/e278ccc4fc41 -- disable regexp tracer on arm, there's something wrong with it and I haven't had a chance to figure out what.

http://hg.mozilla.org/tracemonkey/rev/9d4c8de84579 -- the bulk of the fixes; mostly fallout from bug 462228 but a few other bugs.

We should get a new bug on file to look at/fix the regexp tracer -- one problem that I had to fix was that the epilogue on ARM wasn't generating a mov fp, sp before popping registers -- all the side exits always have that before jumping to the epilogue, but the regexp code exit that was taken didn't seem to have this -- just an:

  eor r2, r2, r2  (mov r2, #0)
  b  EXIT

We should figure out whether the fp -> sp munging belongs here or if it always belongs in the epilogue; right now it's emitted in both places, and I'm not sure that that's necessary.  Emitting it in the epilogue caused things to stop crashing at least, but now the regexp compiler returns the wrong results... should be simple to step through and see why, but I haven't had a chance to look yet.
Duplicate of this bug: 463975
Duplicate of this bug: 463951
Flags: blocking1.9.1?
it builds fine (regardless some crashes in runtime , tracked down in other bugs) so I am removing the "block 1.9.1 ?" flag.
Flags: blocking1.9.1?
This shouldn't be open, it's been fixed for a while.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.