FF launches Mplayer/VLC instead of Realplayer. Konquerer works.

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: juergen.naser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.3) Gecko/2008092700 SUSE/3.0.3-5.1 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.3) Gecko/2008092700 SUSE/3.0.3-5.1 Firefox/3.0.3

When trying to listen to the amazon songs always mplayer starts. Realplayer 10 is installed. In the same configuration Konquerer works well. I tried the following:
- add on mediaplayerconnectivity0.9.1 is installed. doesnt help.
- remove the mplayer -rm files from /usr/lib/browser-plugins (the helix.so is in this directory!): doesnt help
- uninstall mplayer: now vlc starts instead of realplayer.
- uninstall also vlc: realplayer starts and plays the song

With Konquerer the playing of the song always works. But Firefox is my favoritebrowser, and I dont want to uninstall mplayer/vlc every time I want to hear songs from amazon....

When I copy the URL and play the URL with realplayer manually (copy the URL into the "site open" menu) it works


Reproducible: Always

Steps to Reproduce:
1.Open amazon
2.klick on a song
3.mplayer/vlc starts instead of realplayer
Actual Results:  
see details

Expected Results:  
see details

see details
Read https://help.ubuntu.com/community/RealPlayerInstallationMethods and
if you want to register the external protocol rtsp:// read http://support.mozilla.com/en-US/kb/The+protocol+is+not+associated+with+any+program

Firefox is using this search order : 
Content Type X received -> handled internal (example text/html) -> plugin available (look in about:plugins) -> external helper application -> save as window

Look in about:plugins if any plugins wants to handle audio/x-pn-realaudio , either configure this plugin to not handle this or remove the plugin.

marking invalid because this is a support request and i can't see a bug.
We have a bug for plugin management (specify which plugin is used for mime-type X), search for it
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.