support.ati.com: Browser hangs and eventually reports error trying to submit bug report to ATI Linux driver support site. The same URL/report on Firefox 2.x on Windows succeeds

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: wprins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

I've been trying for some time to report a bug re the Linux ATI driver using their support site URL (as above), but it fails every time using Firefox 3.x (from my Ubuntu install.)  



Reproducible: Always

Steps to Reproduce:
To reproduce the problem:
1.) Install Ubuntu 8.10 (Intrepid), apply all updates.
2.) Using the installed firefox, visit the URL: http://support.ati.com/ics/survey/survey.asp?deptID=894&surveyID=508&type=web
3.) Attempt to make a bug report and click submit.
4.) Watch it wait/try for a couple of minutes and eventually fail.


Actual Results:  
The browser hangs and eventually reports an error (failing to complete the bug report on the ATI site.)

Expected Results:  
The browswer should succeed and navigate the ATI bug report completion page.

I tested using Firefox 2.x on Windows, so while I don't think the OS is relevant there is nevertheless a possibility that this may be somehow OS related.  I'll try and do a test to confirm.

All tests were done with no theming or any special add-ons installed.
(Reporter)

Comment 1

10 years ago
OK, I've now tested using Firefox 3.0.3 on Windows XP which actually succeeded.  So this problem is after all apparently specific to the Ubuntu Firefox build (possibly only to 8.10 release?) 

The version I've tested with on Windows: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Did you try the firefox safemode ?
Did you try a new Firefox profile for testing ?

There should not be a plattform difference in submitting forms.
IF this is ubuntu specific you should report this to ubuntu
(Reporter)

Comment 3

10 years ago
I'll test as requested and report back.  If this problem is indeed totally Ubuntu specific I'll report it to Ubuntu.  Thanks for your reply.
(Reporter)

Comment 4

10 years ago
OK, I've created a new user on the OS to test with (thus implicitly new profile) and from that user started Firefox in safe mode, disabling everything.  The hanging behaviour is still unfortunately the same however.  

I'll file a bug report with the Ubuntu project.

Thanks for your prompt response.
(Reporter)

Comment 5

10 years ago
For reference, the bug report in Ubuntu's Launchpad bug tracker, is here:
https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/296563
It could be still a platform depending bug, you could download and test a build from Mozilla.org....
(Reporter)

Comment 7

10 years ago
Only just noticed this report I made some time ago, this turned out to be a MTU/router issue, where for whatever reason traffic between ati's site and the test PC would not work due to too large MTU being used.  Windows was more forgiving (was using a smaller MTU) and hence worked while Linux/Ubuntu was not.  Anyway, I'm consequently closing this as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.