If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ imgRequest::NotifyProxyListener(imgRequestProxy*) ]

RESOLVED DUPLICATE of bug 457496

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 457496
9 years ago
9 years ago

People

(Reporter: John, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081109 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081109 Minefield/3.1b2pre

Crashes [@ imgRequest::NotifyProxyListener(imgRequestProxy*) ]

Bug 441563 was Resolved Fixed and had the same crash report title, but someone said this was a different issue and to create a new bug (I originally posted in the previous bug report, as I'm hesitant to create duplicates)

Reproducible: Always

Steps to Reproduce:
1) Go to http://www.gasbuddy.com/GB_Map_Gas_Prices.aspx
2) Scroll around on the interactive map for about 2 minutes (at this point, the
browser leaks massive amounts of memory. For me, it was using 600MB and I only
have 1GB, and it crashes soon after. could be memory corruption.
Actual Results:  
After scrolling around the map for a bit, the browser crashes

Expected Results:  
Shouldn't crash

Crash Report: http://crash-stats.mozilla.com/report/index/6092cbf3-ae98-11dd-9c7f-001cc45a2c28
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441563
(Reporter)

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I can't reproduce this, but I suspect you're seeing memory exhaustion (I scrolled around and around and around until Firefox was 2+ GB, and never saw a crash).

Also, it looks to me like the GasBuddy map is leaking memory by holding on to references to the images, or by simply overlaying images, or something. In any case, closing the tab that the map was in reduced my Firefox memory usage from 2+ gigs to 250 MB, which indicates to me that the problem is _probably_ in the GasBuddy javascript.

Please feel free to reopen if you have more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
Sorry, but I'm also not able to get Minefield crashing. Using d&d and the arrows gives me at maximum 96MB of memory consumption but immediately goes back to ~75MB again.

Please use a fresh profile without any extensions or simply start in safe mode. Which way of scrolling do you use?
0  	xul.dll  	imgRequest::NotifyProxyListener  	 modules/libpr0n/src/imgRequest.cpp:230
1 	xul.dll 	imgRequestProxy::Clone 	modules/libpr0n/src/imgRequestProxy.cpp:349
2 	xul.dll 	nsImageBoxFrame::UpdateImage 	layout/xul/base/src/nsImageBoxFrame.cpp:283
3 	xul.dll 	nsStyleContext::GetStyleDisplay 	layout/style/nsStyleStructList.h:95
4 	xul.dll 	nsImageBoxFrame::DidSetStyleContext 	layout/xul/base/src/nsImageBoxFrame.cpp:422
5 	xul.dll 	nsFrameManager::ReResolveStyleContext 	layout/base/nsFrameManager.cpp:1230

Timeless, is it a dupe of bug 457496?

Comment 5

9 years ago
comment 2 from joe indicates he's guessing an OOM failure, bug 457496 seems to support that. if the rest of his leak comment is correct and you can't trigger the crash again, then yeah, it's a reasonably likely dupe.

Updated

9 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 457496
You need to log in before you can comment on or make changes to this bug.