Closed Bug 463951 Opened 11 years ago Closed 11 years ago

recent change to NativeARM.cpp broke windows ce build

Categories

(Core :: JavaScript Engine, defect, blocker)

All
Windows CE
defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 463879

People

(Reporter: dougt, Assigned: dougt)

References

()

Details

Building deps for /c/mozilla-central/js/src/nanojit/NativeARM.cpp
/c/mozilla-central/build/wince/tools/bin/arm-wince-gcc -FoNativeARM.obj -c  -DAVMPLUS_ARM -DFEATURE_NANOJIT -DJS_TRACER -DOSTYPE=\"WINCE\" -DOSARCH=WINCE -DEXPORT_JS_API  -DJS_USE_SAFE_ARENA  -I/c/mozilla-central/js/src -I.  -I./dist/include   -I./dist/include/js -I/c/mozilla-central/objdir-wm6/xulrunner/dist/include/nspr -I/sdk/include -I/c/mozilla-central/js/src       -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb  -DNDEBUG -DTRIMMED -O1   -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DWINVER=0x500 -D_WIN32_WINNT=0x500 -D_WIN32_IE=0x0500 -DX_DISPLAY_MISSING=1 -DWINCE=1 -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DNEW_H=\<new\> -DWIN32_LEAN_AND_MEAN=1 -DD_INO=d_ino -DCPP_THROW_NEW=throw\(\) -DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /c/mozilla-central/js/src/nanojit/NativeARM.cpp
c:\Program Files\Microsoft Visual Studio 9.0\VC\ce\bin\x86_arm\cl.exe /I"c:\Program Files\Windows Mobile 6 SDK\PocketPC\Include\Armv4i" /I"c:/mozilla-central/build/wince/shunt/include/" /FI"mozce_shunt.h" /DMOZCE_STATIC_BUILD /DUNICODE /D_UNICODE_ /DARM /D_ARM_ /DWINCE /D_WIN32_WCE=0x502 /DUNDER_CE /DWIN32_PLATFORM_WFSP /D_WINDOWS /DNO_ERRNO /Zc:wchar_t- /GS- /GR- /fp:fast -FoNativeARM.obj -c -DAVMPLUS_ARM -DFEATURE_NANOJIT -DJS_TRACER -DOSTYPE=\""WINCE"\" -DOSARCH=WINCE -DEXPORT_JS_API -DJS_USE_SAFE_ARENA -Ic:/mozilla-central/js/src -I. -I./dist/include -I./dist/include/js -Ic:/mozilla-central/objdir-wm6/xulrunner/dist/include/nspr -IC:/mozilla-build/msys/sdk/include -Ic:/mozilla-central/js/src -GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -O1 -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DWINVER=0x500 -D_WIN32_WINNT=0x500 -D_WIN32_IE=0x0500 -DX_DISPLAY_MISSING=1 -DWINCE=1 -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1!
  -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DNEW_H=<new> -DWIN32_LEAN_AND_MEAN=1 -DD_INO=d_ino -DCPP_THROW_NEW=throw() -DMOZ_DLL_SUFFIX=\"".dll"\" -DJS_THREADSAFE=1 -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT c:/mozilla-central/js/src/nanojit/NativeARM.cpp 
NativeARM.cpp
c:/mozilla-central/build/wince/shunt/include/windows.h(2) : warning C4005: 'GetProcAddress' : macro redefinition
        c:\Program Files\Windows Mobile 6 SDK\PocketPC\Include\Armv4i\winbase.h(322) : see previous definition of 'GetProcAddress'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(88) : error C2039: 'explicitSavedParams' : is not a member of 'nanojit::LirBuffer'
        c:\mozilla-central\js\src\nanojit\LIR.h(830) : see declaration of 'nanojit::LirBuffer'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(131) : error C2039: 'jmp' : is not a member of 'nanojit::GuardRecord'
        c:\mozilla-central\js\src\nanojit\Native.h(67) : see declaration of 'nanojit::GuardRecord'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(160) : error C2039: 'explicitSavedParams' : is not a member of 'nanojit::LirBuffer'
        c:\mozilla-central\js\src\nanojit\LIR.h(830) : see declaration of 'nanojit::LirBuffer'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(330) : error C2556: 'void nanojit::Assembler::nPatchBranch(nanojit::NIns *,nanojit::NIns *)' : overloaded function differs only by return type from 'nanojit::NIns *nanojit::Assembler::nPatchBranch(nanojit::NIns *,nanojit::NIns *)'
        c:\mozilla-central\js\src\nanojit\Assembler.h(329) : see declaration of 'nanojit::Assembler::nPatchBranch'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(330) : error C2040: 'nanojit::Assembler::nPatchBranch' : 'void (nanojit::NIns *,nanojit::NIns *)' differs in levels of indirection from 'nanojit::NIns *(nanojit::NIns *,nanojit::NIns *)'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(719) : error C2039: 'asm_adjustBranch' : is not a member of 'nanojit::Assembler'
        c:\mozilla-central\js\src\nanojit\Assembler.h(163) : see declaration of 'nanojit::Assembler'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(1120) : error C2511: 'nanojit::NIns *nanojit::Assembler::asm_branch(bool,nanojit::LInsp,nanojit::NIns *)' : overloaded member function not found in 'nanojit::Assembler'
        c:\mozilla-central\js\src\nanojit\Assembler.h(163) : see declaration of 'nanojit::Assembler'
c:/mozilla-central/js/src/nanojit/NativeARM.cpp(1242) : error C3861: 'assignSavedParams': identifier not found
make[5]: *** [NativeARM.obj] Error 2
make[5]: Leaving directory `/c/mozilla-central/objdir-wm6/xulrunner/js/src'
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463879
Version: psm1.01 → Trunk
You need to log in before you can comment on or make changes to this bug.