Closed Bug 463975 Opened 11 years ago Closed 11 years ago

nanojit build broken on arm

Categories

(Core :: JavaScript Engine, defect)

ARM
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 463879

People

(Reporter: blassey, Unassigned)

Details

(Keywords: mobile)

I'm seeing roughly the same errors building for maemo and wince.

In file included from /home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:40:
/home/blassey/clean/mozilla-central/js/src/nanojit/nanojit.h:98:30: warning: anonymous variadic macros were introduced in C99
/home/blassey/clean/mozilla-central/js/src/nanojit/nanojit.h:125:23: warning: anonymous variadic macros were introduced in C99
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'nanojit::NIns* nanojit::Assembler::genPrologue()':
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:88: error: 'class nanojit::LirBuffer' has no member named 'explicitSavedParams'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'void nanojit::Assembler::nFragExit(nanojit::LIns*)':
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:131: error: 'struct nanojit::GuardRecord' has no member named 'jmp'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'nanojit::NIns* nanojit::Assembler::genEpilogue()':
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:160: error: 'class nanojit::LirBuffer' has no member named 'explicitSavedParams'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: At global scope:
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:329: error: prototype for 'void nanojit::Assembler::nPatchBranch(nanojit::NIns*, nanojit::NIns*)' does not match any in class 'nanojit::Assembler'
/home/blassey/clean/mozilla-central/js/src/nanojit/Assembler.h:329: error: candidate is: nanojit::NIns* nanojit::Assembler::nPatchBranch(nanojit::NIns*, nanojit::NIns*)
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:329: error: 'void nanojit::Assembler::nPatchBranch(nanojit::NIns*, nanojit::NIns*)' cannot be overloaded
/home/blassey/clean/mozilla-central/js/src/nanojit/Assembler.h:329: error: with 'nanojit::NIns* nanojit::Assembler::nPatchBranch(nanojit::NIns*, nanojit::NIns*)'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'void nanojit::Assembler::asm_store64(nanojit::LIns*, int, nanojit::LIns*)':
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:488: warning: unused variable 'valResv'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: At global scope:
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:719: error: no 'nanojit::NIns* nanojit::Assembler::asm_adjustBranch(nanojit::NIns*, nanojit::NIns*)' member function declared in class 'nanojit::Assembler'
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'void nanojit::Assembler::asm_fcmp(nanojit::LIns*)':
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:1101: warning: comparison is always false due to limited range of data type
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:1101: warning: comparison is always true due to limited range of data type
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:1101: warning: comparison is always true due to limited range of data type
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: At global scope:
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp:1119: error: prototype for 'nanojit::NIns* nanojit::Assembler::asm_branch(bool, nanojit::LIns*, nanojit::NIns*)' does not match any in class 'nanojit::Assembler'
/home/blassey/clean/mozilla-central/js/src/nanojit/Assembler.h:316: error: candidate is: nanojit::NIns* nanojit::Assembler::asm_branch(bool, nanojit::LIns*, nanojit::NIns*, bool)
/home/blassey/clean/mozilla-central/js/src/nanojit/NativeARM.cpp: In member function 'void nanojit::Assembler::asm_loop(nanojit::LIns*, nanojit::NInsList&)':
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463879
You need to log in before you can comment on or make changes to this bug.