Details/Description textbox missing from create/edit event/task dialog

RESOLVED FIXED in 1.0b1

Status

defect
--
major
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: jrossiter, Assigned: ssitter)

Tracking

Trunk
1.0b1

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081106 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081106 Lightning/1.0pre ID:20081106051601 Shredder/3.0b1pre ID:20081106035918

(I'm almost positive this is a dupe somewhere, but I couldn't find one.)

Creating or editing events lacks the Details textbox in the event dialog.  Unclear when this started, but I noticed it several days ago.

Reproducible: Always

Steps to Reproduce:
1. Create Event or Edit Event
Actual Results:  
Dialog is missing the details field

Expected Results:  
Dialog has details field

Current configuration is two WebDAV-based ICS files (not sure if this matters or not - doubt it).
(Assignee)

Comment 1

11 years ago
Do you mean the Description field? This works fine for me using Lightning 1.0pre (20081109044044) with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081109 Shredder/3.0b1pre.

Maybe you just resized the dialog to hide the Description field? In addition I'd like you to check Tools > Error Console for error messages during your workflow.
(Reporter)

Comment 2

11 years ago
Definitely not a sizing issue - I checked that from all angles.  Running 1920x1600 I can resize the dialog to larger than full screen and there's no description field.  I've also replicated the issue on two machines (same config on both).

Error Console, from a clean launch of Shredder, in First to Last order.  The last error appear when opening calendar view for the first time.

Two Times:
Warning: Unknown property '-moz-opacity'.  Declaration dropped.
Source File: data:text/css,%2F*%20*****%20BEGIN%20LICENSE%20BLOCK%20*****%0A%20*%20Version%3A%20MPL%201.1%0A%20*%0A%20*%20The%20contents%20of%20this%20file%20are%20subject%20to%20the%20Mozilla%20Public%20License%20Version%0A%20*%201.1%20(the%20%22License%22)%3B%20you%20may%20not%20use%20this%20file%20except%20in%20compliance%20with%0A%20*%20the%20License.%20You%20may%20obtain%20a%20copy%20of%20the%20License%20at%0A%20*%20http%3A%2F%2Fwww.mozilla.org%2FMPL%2F%0A%20*%0A%20*%20Software%20distributed%20under%20the%20License%20is%20distributed%20on%20an%20%22AS%20IS%22%20basis%2C%0A%20*%20WITHOUT%20WARRANTY%20OF%20ANY%20KIND%2C%20either%20express%20or%20implied.%20See%20the%20License%0A%20*%20for%20the%20specific%20language%20governing%20rights%20and%20limitations%20under%20the%0A%20*%20License.%0A%20*%0A%20*%20The%20Original%20Code%20is%20Adblock%20Plus.%0A%20*%0A%20*%20The%20Initial%20Developer%20of%20the%20Original%20Code%20is%0A%20*%20Wladimir%20Palant.%0A%20*%20Portions%20created%20by%20the%20Initial%20Developer%20are%20Copyright%20(C)%202006-2007%0A%20*%20the%20Initial%20Developer.%20All%20Rights%20Reserved.%0A%20*%0A%20*%20Contributor(s)%3A%0A%20*%0A%20*%20*****%20END%20LICENSE%20BLOCK%20*****%20*%2F%0A%0A%40namespace%20url(%22http%3A%2F%2Fwww.w3.org%2F1999%2Fxhtml%22)%3B%0A%0Aa.abp-objtab-09297484433920783%20%7B%0A%09display%3A%20inline%20!important%3B%0A%09visibility%3A%20hidden%20!important%3B%0A%09float%3A%20left%20!important%3B%0A%09position%3A%20relative%20!important%3B%0A%09overflow%3A%20visible%20!important%3B%0A%09width%3A%200px%20!important%3B%0A%09height%3A%200px%20!important%3B%0A%09z-index%3A%2065535%20!important%3B%0A%09-moz-opacity%3A%200.2%20!important%3B%0A%09text-decoration%3A%20none%20!important%3B%0A%7D%0A%0Aa.abp-objtab-09297484433920783%3Ahover%20%7B%0A%09-moz-opacity%3A%200.8%20!important%3B%0A%7D%0A%0Aa.abp-objtab-09297484433920783.visible%20%7B%0A%09visibility%3A%20visible%20!important%3B%0A%7D%0A%0Aa.abp-objtab-09297484433920783%20div%20%7B%0A%09display%3A%20inline%20!important%3B%0A%09visibility%3A%20visible%20!important%3B%0A%09float%3A%20left%20!important%3B%0A%09position%3A%20relative%20!important%3B%0A%09width%3A%20auto%20!important%3B%0A%09height%3A%20auto%20!important%3B%0A%09border-style%3A%20ridge%20!important%3B%0A%09background%3A%20white%20!important%3B%0A%09color%3A%20black%20!important%3B%0A%09cursor%3A%20pointer%20!important%3B%0A%09white-space%3A%20nowrap%20!important%3B%0A%09font-family%3A%20Arial%2CHelvetica%2CSans-Serif%20!important%3B%0A%09font-size%3A%2010px%20!important%3B%0A%09font-style%3A%20normal%20!important%3B%0A%09font-variant%3A%20normal%20!important%3B%0A%09font-weight%3A%20normal%20!important%3B%0A%09letter-spacing%3A%20normal%20!important%3B%0A%09line-height%3A%20normal%20!important%3B%0A%09text-align%3A%20center%20!important%3B%0A%09text-decoration%3A%20none%20!important%3B%0A%09text-indent%3A%200px%20!important%3B%0A%09text-transform%3A%20none%20!important%3B%0A%09direction%3A%20ltr%20!important%3B%0A%09padding%3A%200px%205px%20!important%3B%0A%09border-width%3A%200px%202px%202px%202px%20!important%3B%0A%09border-color%3A%20black%20!important%3B%0A%09-moz-border-radius-topleft%3A%200px%20!important%3B%0A%09-moz-border-radius-topright%3A%200px%20!important%3B%0A%09-moz-border-radius-bottomleft%3A%2010px%20!important%3B%0A%09-moz-border-radius-bottomright%3A%2010px%20!important%3B%0A%7D%0A%0Aa.abp-objtab-09297484433920783.ontop%20div%20%7B%0A%09border-width%3A%202px%202px%200px%202px%20!important%3B%0A%09-moz-border-radius-topleft%3A%2010px%20!important%3B%0A%09-moz-border-radius-topright%3A%2010px%20!important%3B%0A%09-moz-border-radius-bottomleft%3A%200px%20!important%3B%0A%09-moz-border-radius-bottomright%3A%200px%20!important%3B%0A%7D%0A
Line: 36

One Time:
Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Twelve Times:
Error: a._updateVisibleText is not a function
Source File: chrome://global/content/bindings/textbox.xml
Line: 210

One Time:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]
Jay, are you using a 3rd party theme? If yes, could you try to return to the default theme and see if that fixes the issue?
(Reporter)

Comment 4

11 years ago
Default theme, no other themes even installed
Jay, can you please try again with a fresh profile, and just Lightning installed as an extension?
(Reporter)

Comment 6

11 years ago
A new profile does work.

Using the existing upgraded profile, I removed all extensions except for Lightning, and reverted all calendar prefs in about:config / prefs.js - no luck.  Still didn't function.
(Reporter)

Comment 7

11 years ago
I've finally managed to figure this out - sort of.

By trashing localstore.rdf and letting it rebuild, my calendar view went back to defaults and the Description field re-appeared in my dialog.

I'm attaching a copy of localstore.rdf that has been stripped of all personally identifiable information (or so I believe), since it includes a lot of detail about my IMAP accounts.
<RDF:Description RDF:about="chrome://calendar/content/calendar-event-dialog.xul#description-row" collapsed="true"/> is the culprit, but I couldn't find any function where this part of the dialog could be collapsed.
Keywords: qawanted

Updated

11 years ago
Duplicate of this bug: 467515
Summary: Details textbox missing from create/edit event dialog → Details/Description textbox missing from create/edit event/task dialog

Comment 10

10 years ago
As Jay/Martin suggested, I removed collapsed="true" from my localstore.rdf and that fixed the problem after I restarted Thunderbird.

That was on a Vista box, so I don't think the problem is only on XP.

Note that collapsed="true" existed in localstore.rdf BEFORE I upgraded, so apparently TB 2.x / Lightning 0.9 ignored it, but TB 3.x / Lightning 1.0pre use it.

Also, on a different computer I had collapsed="" instead of collapsed="true".  There was no problem when I upgraded that computer.
(Assignee)

Comment 11

10 years ago
I finally managed to reproduce the issue:

Sunbird 0.5 used the old event dialog: Using the [More >>] and [<< Less] button the description row was collapsed and stored in localstore.rdf as:

"chrome://calendar/content/calendar-event-dialog.xul#description-row"

Sunbird 0.7-0.9 used the new sun-prototype dialog from calendar/prototypes that was stored in localstore.rdf as:

"chrome://calendar/content/sun-calendar-event-dialog.xul#description-row"

Sunbird 1.0pre renamed and moved the dialog from calendar/prototypes to calendar/base and is now stored in localstore.rdf again as:

"chrome://calendar/content/calendar-event-dialog.xul#description-row"

--> If Sunbird/Lightning 0.5 was used in the past and the event dialog was in Less mode the collapsed attribute is set for description row in localstore.rdf. If the user now upgrades from 0.5/0.7/0.8/0.9 to 1.0pre the collapsed attribute is applied, the description row is missing.
Assignee: nobody → ssitter
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 12

10 years ago
This patch aligns the row ID with the IDs used for other rows in the dialog and therefore avoids the issue with the stored collapsed attribute.
Attachment #369871 - Flags: review?(philipp)
(Assignee)

Updated

10 years ago
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
Comment on attachment 369871 [details] [diff] [review]
change row ID to event-grid-description-row

r=philipp
Attachment #369871 - Flags: review?(philipp) → review+
(Assignee)

Comment 14

10 years ago
Pushed to comm-central <https://hg.mozilla.org/comm-central/rev/b04e69fb34a1>
--> Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.