In lightning, Calendar/Properties, in "E-Mail" I cannot associate the calendar to a new email address, other than my own email address

RESOLVED DUPLICATE of bug 205659

Status

--
enhancement
RESOLVED DUPLICATE of bug 205659
10 years ago
9 years ago

People

(Reporter: andersk, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080914)

There are a number of persons in my work group, say. I have their calendars visible, loaded via webdav (or Funambol synchronization). Opening up one of the calendar's properties there is a field "E-Mail". I would like to associate the calendar to the person's email address. But the only email addresses I can assign to is given in the combo, namely my own email addresses (from the accounts in thunderbird, perhaps?). 

When I open New Event-> Invite Attendees I would like the email address to automatically load the calendar associated with that email address.

Reproducible: Always

Steps to Reproduce:
1. In lightning, right click on Calendar -> Properties
2. Try to change E-Mail to someone in your address book, for instance


Expected Results:  
I would like to associate a calendar with an arbitrary email address, presumably from my address book

Maybe there is another way this is supposed to be used? How can I associate calendars with different people?

Comment 1

10 years ago
That's not the purpose of that property. It's the email identity used for sending out iMIP.
We don't support delegation yet, i.e. you cannot act on behalf of someone else.
I know we already have a iTIP delegation bug, thus think this is INVALID or a dupe.
(Reporter)

Comment 2

10 years ago
No, this is not delegation. I am not acting on behalf of someone else.

This is only that I want to *see* other person's calendars, and associate them - in my lightning - with an email address. How else is free/busy suppose to work in invite attendees?
(Reporter)

Comment 3

10 years ago
Maybe I should add a bug/request explaining this for Invite Attendees instead. The problem is still that one needs to associate a calendar with a person, which has nothing to do with delegation.

Comment 4

10 years ago
If I understand you correctly, you want to create an event with a different organizerId than your configured email identities, right?

Comment 5

10 years ago
(In reply to comment #2)
> This is only that I want to *see* other person's calendars, and associate them
> - in my lightning - with an email address. How else is free/busy suppose to
> work in invite attendees?

I think that maybe andersk@sverige.nu is using ICS calendars (or some provider that doesn't directly support free/busy info) and is trying to use the attendee's email address as a primary key...  When an organizer types the attendee's email address in the Invite Attendees dialog he wants Lightning to get the free/busy info from the attendee's calendar in his calendar list.

Perhaps this is the same as bug 205659 ("Publish/Retrieve freebusy aggregate calendar/file (.ifb/.vfb)").  However, I think that bug wants to use the attendee's email address to find the contact in the Thunderbird address book which will contain a URL to his calendar or free/busy file.  I think that's better because then the organizer doesn't have to subscribe to every attendee's calendar.

Comment 6

10 years ago
By the way, perhaps it would be more clear if the label in the calendar properties said "Organizer" instead of "Email".

Comment 7

10 years ago
No, it's the email identity that is used for sending iMIP (mail-based iTIP). The organizer id of storage/ics calendars is currently derived out of it, but this need not be the case.
(Reporter)

Comment 8

10 years ago
(In reply to comment #5)
> (In reply to comment #2)
> > This is only that I want to *see* other person's calendars, and associate them
> > - in my lightning - with an email address. How else is free/busy suppose to
> > work in invite attendees?
> 
> I think that maybe andersk@sverige.nu is using ICS calendars (or some provider
> that doesn't directly support free/busy info) and is trying to use the
> attendee's email address as a primary key...  When an organizer types the
> attendee's email address in the Invite Attendees dialog he wants Lightning to
> get the free/busy info from the attendee's calendar in his calendar list.

Yes, that's it! I have the the calendar, either through ics-file on webdav or synchronization with Funambol plug-in. That is sufficient statistics to provide free/busy information.... So this is exactly what I am looking for. Thanks for translating...


> 
> Perhaps this is the same as bug 205659 ("Publish/Retrieve freebusy aggregate
> calendar/file (.ifb/.vfb)").  However, I think that bug wants to use the
> attendee's email address to find the contact in the Thunderbird address book
> which will contain a URL to his calendar or free/busy file.  I think that's
> better because then the organizer doesn't have to subscribe to every attendee's
> calendar.

Indeed, that will work, too. That would often be the best solution. Here, if I have the calendars of my work group I might want to use that. But this solution would work, too.

Comment 9

10 years ago
So this is a dupe to bug 205659?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 205659
You need to log in before you can comment on or make changes to this bug.