Closed Bug 464010 Opened 11 years ago Closed 11 years ago

regexp.test doesn't work on 64 bit linux builds

Categories

(Core :: JavaScript Engine, defect, P1, blocker)

x86
Linux
defect

Tracking

()

VERIFIED FIXED
mozilla1.9.1b2

People

(Reporter: smaug, Unassigned)

References

Details

(Keywords: verified1.9.1)

Attachments

(1 file)

regexp.text doesn't seem to work on 64 bit linux builds, and so location bar is broken.

/foo/.test("bar"); should return false, but causes
Error: /foo/.test is not a function
Source File: javascript:%20/foo/.test("bar");
Priority: -- → P1
Btw, this prevents running *any* tests on 64 bit linux.
Summary: regexp.text doesn't work on 64 bit linux builds → regexp.test doesn't work on 64 bit linux builds
Flags: blocking1.9.1?
Target Milestone: --- → mozilla1.9.1b2
I accidentally committed this last night (see the #ifdef at the end):

http://hg.mozilla.org/mozilla-central/rev/e278ccc4fc41

but JS_TRACER should be defined in this case, no?
The ifdef should go regardless of whether it's causing this bug or not..
jstracer and jit should be off for x86-64.

Is this bug reproducable on mac-ppc also?
Ah, I missed the "else" in Makefile.in.  Then yeah, this is the problem.
(In reply to comment #4)
> 
> Is this bug reproducable on mac-ppc also?

Yes same bug on mac ppc today.
Attachment #347326 - Flags: review+
Flags: blocking1.9.1? → blocking1.9.1+
Checked in; ideally we'd also rebuild today's x86-64 nightly, but I don't know how to do that just for that one machine..
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 464182
this is covered by a number of regexp related tests.
Flags: in-testsuite+
Flags: in-litmus-
v 1.9.1, 1.9.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.