Closed Bug 464074 Opened 12 years ago Closed 6 years ago

hotmail.com - Can't type/focus message body when composing mail in Hotmail using a non-Firefox UA

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: wiepiewiepie, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)

When opening hotmail, I get the next information:
"Upgrade your web browser

We recommend that you upgrade your web browser so you can get the most out of Windows Live Hotmail. Upgrading should only take a few minutes. To get started, choose one of the browsers below:

    * Microsoft Internet Explorer 
    * Mozilla Firefox
    * Apple Safari (these are links)

If you don't want to upgrade right now you can still continue to Windows Live Hotmail, but some parts of it may not work and it may not be displayed properly."

As I'm using Camino, and there's no link for Camino, I chose to continue anyway. (I tried updating Camino, but it is fully up to date). But as I was warned: some parts did not work and/or were shown correctly.

As I try to send a mail, wether a new one, a reply of forward, the box that is meant for typing in your message does not work. I can't get a cursor there, not by clicking, nor by pushing tab. So I can't write any email. Very frustrating.

Reproducible: Always

Steps to Reproduce:
1. Open hotmail using camino
2. Continue after the 'warning, update your browser'
3. Try to type some kind of email
Actual Results:  
As I try to send a mail, wether a new one, a reply of forward, the box that is meant for typing in your message does not work. I can't get a cursor there, not by clicking, nor by pushing tab.

Expected Results:  
I should have had a box to type in.
People using both 1.6.4 and 2.0 alphas have been reporting that it works if and only if your User Agent is spoofed to the corresponding version of Firefox (2.0 for 1.6.4, 3.0 for the nightlies).

So this seems to be yet another painfully stupid Hotmail UA sniffing bug (surprise, surprise). Please contact Hotmail support and explain to them that Firefox is not the only browser based on Gecko and that you don't appreciate having your browser pointlessly locked out because they continue to ignore best practices in browser capability.

However, they have many years of history with exactly this behavior, and have shown little indication that they plan to change. If you enjoy having a choice in browsers, you may want to investigate changing to another webmail provider.
Assignee: nobody → english-us
Component: General → English US
Product: Camino → Tech Evangelism
QA Contact: general → english-us
Hardware: PC → All
Summary: Can't send mail (box for typing is shown but can't be clicked on/typed in, there's no cursor) → Can't send mail in new Hotmail interface using a non-Firefox UA
Wow, that was fast! Thank you so much, I really appreciate it.

I did report it to Hotmail, but whether that helps...
This is a dupe of bug 396259, AFAICT.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
OS: Mac OS X → All
Resolution: --- → DUPLICATE
Duplicate of bug: 396259
Duplicate of this bug: 465156
This really sounds like it's a dupe of bug 457791, not bug 396259.  (Frankly, I'd dupe bug 457791 here, since the STR are more clear here).

Bug 396259 is about being unable to *access* the new "Full" version of Hotmail and being sent to the "Classic" version instead, as near as I can tell from the "recent" comments there.

This bug, and bug 465156, and bug 457791, AFAICT, is about the inability to focus the message body field to input any text (it's disabled, actually).  I used the fake account in bug 463203 comment 14 to test this.  Using a literal Firefox UA works fine.
Blocks: geckoisgecko
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Can't send mail in new Hotmail interface using a non-Firefox UA → Can't type/focus message body when composing mail in Hotmail using a non-Firefox UA
Status: UNCONFIRMED → NEW
Ever confirmed: true
bug 463203 is similar to this one, only on Ubuntu.
Duplicate of this bug: 475767
Duplicate of this bug: 478702
Summary: Can't type/focus message body when composing mail in Hotmail using a non-Firefox UA → hotmail.com - Can't type/focus message body when composing mail in Hotmail using a non-Firefox UA
Duplicate of this bug: 457791
both hotmail and Camino are RIP.
If there is a bug on Desktop in the future with http://mail.live.com/ open a new bug.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 12 years ago6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.