Account wizard tries to create IMAP/POP account on unknown news: url

VERIFIED DUPLICATE of bug 48438

Status

SeaMonkey
MailNews: Account Configuration
P2
major
VERIFIED DUPLICATE of bug 48438
18 years ago
14 years ago

People

(Reporter: David Hallowell, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+], URL)

(Reporter)

Description

18 years ago
Steps to reproduce:
1. Open a news: url in a browser window for a server that you currently don't
have an identity set up for e.g. news://news.mozilla.org/netscape.test
(If you can't think of a news server to use create a fresh profile and use the
above example)

What happens:
The mail/news window will appear with the news server added and an account
wizard dialog will pop up but there's no content in the dialog box just the
Cancel back forward and finish buttons which all appear enabled but only the
cancel button does anything

2. Cancel the wizard dialog as there's nothing you can do with it.

3. Try to send a message to the group

What happens:
The faulty wizard appears again, the only option is to cancel. Posting will fail.

4. Cancel the wizard again

5. Go to Mail/News account settings (from the Edit menu in MailNews)
6. Try to add a new account.

What happens:
The non functional dialog box pops up.

Expected results:
Clicking on a news:// url should subscribe you to the group and also add the
server to the list in mail/news account preferences (this does happen). The
account wizard dialog should appear correctly and enable you to add your
details. If cancel is pressed on the wizard it should either assume your default
identity or ask again when attempting to post.

Adding new accounts using the wizard works fine until you try and use a news://url

Build ID:
2000072508  Windows NT 4.0

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 1

18 years ago
Repro for me until I try and add a new account, which works. Then when I send a 
new msg, the functional Account Wizard shows up. Someone else please see if you 
can repro.
072508 nt4

Comment 2

18 years ago
Last message from me, sorry - old login.

Comment 3

18 years ago
Perhaps the same problem (although details are a bit different).
1. Open a news: url for a server not currently set up for.

What happens:
mailnews window appears with the news server added. Account wizard pops up, but
(after the identity page), asks whether it's a pop or imap account!!!

If you follow through with the wizard, *another* account is created. If you open
the mailnews account settings, both appear to be mail accounts.

If you cancel the wizard, the next time you start mail the wizard appears again.

(I didn't do any tests with actual posting).

This is on Linux. Build 2000080808.

Comment 4

18 years ago
Build 2000-08-07-15M18: NT4

I duplicated len@intelligenesis.net scenario. In fact the problem becomes a loop 
because if I progress through the Wizard (even though POP and IMAP choices 
display), after exiting and restarting mail then the Account Wizard opens to the 
same Identity dialog. 

If I progress through the Wizard (even though POP and IMAP choices display), it 
creates a mail account. I can then go back to Account Settings, create a new 
account and can see the initial Account Wizard dialog to create any account 
desired, including a news account. After creating a legitimate news account then 
I was able to post messages. After exiting and restarting mail then the Account 
Wizard didn't pop up. It appears that making a legitimate account stops the loop 
cycle.

I haven't reproduced the problem where only the "Cancel" button works as 
described by David Hallowell.
Keywords: nsbeta3

Comment 5

18 years ago
+, P2 per mail triage
Severity: normal → major
Keywords: mail2
Priority: P3 → P2
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18
(Assignee)

Comment 6

18 years ago
updating summary
Summary: Account wizard fails to function correctly after opening a news: URL on an unknown server → Account wizard tries to create IMAP/POP account on unknown news: url
(Reporter)

Comment 7

18 years ago
On more recent builds the I get the same situation that the others are seeing
(getting the mail wizard when you want the news wizard).

This is regression I think.

I'm sure when I've tried this on earlier  builds it used to work. If anyone can
confirm it did we can add a regression keyword to this bug.
(Reporter)

Updated

18 years ago
Blocks: 49319

Comment 8

18 years ago
Marking a duplicate of bug# 48438.

*** This bug has been marked as a duplicate of 48438 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.