If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

lock up when alarm fires while event editor open

RESOLVED WORKSFORME

Status

Calendar
Alarms
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: abrown, Unassigned)

Tracking

Lightning 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Thunderbird 2.0.0.17, lightning 0.9 (also 0.8) x64

If an alarm fires while you are in the middle of editing an event Thunderbird/lightning locks up, neither the event dialog nor the alarm dialog can be dismissed.

May be another manifestation of bug 459351?

TB only runs successfully on the 2nd attempt after killing TB processes after lockup

Reproducible: Always

Steps to Reproduce:
1. Make a new event with a reminder for some time in the near future (say an event in 6 minutes, with a reminder 5 minutes before the event)
2. Immediately add a new event to open event editor dialog
3. Wait for alarm from step 1 to fire

Actual Results:  
Program locks up.  Can't dismiss alarm, can't finish editing.

Expected Results:  
Should be able to dismiss alarm and finish editing new event, probably in that order
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9
Keywords: qawanted
WFM with local storage and local ics calendar using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081127 Lightning/1.0pre Shredder/3.0b1pre.

Reporter, which type of calendar do you use? Have you enabled sound?
(Reporter)

Comment 2

9 years ago
Sound settings are default for lightning (ie play a sound is on, sound=chrome://calendar/content/sound.wav).  Having said that I usually have my speakers muted, though I can't see why that would affect anything.

As to type of calendar, I have 4 calendars, all are iCals, two are stored locally, two are stored as .ics files on a secure (https) webdav server.  I don't recall which one I was editing and which one fired an alarm in my test, but I think it was one of the remote ones.

To confirm, I just tried to reproduce the bug again and found that the bug seems to be gone!  There *was* an update to Thunderbird this morning - maybe it was a thunderbird bug that has been fixed?
Thanks for re-testing. Feel free to re-open the bug report, if you can reproduce it again. Resolving WFM per comment #2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.