Verifyerror when running the earley-boyer v8 javascript test.

RESOLVED FIXED in Q3 11 - Serrano

Status

Tamarin
Virtual Machine
P2
normal
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Chris Peyer, Assigned: Jeff Dyer)

Tracking

unspecified
Q3 11 - Serrano
Bug Flags:
flashplayer-qrb +
flashplayer-bug +
flashplayer-triage +

Details

(Whiteboard: ASC-dependency)

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
Created attachment 347407 [details]
earley-boyer.as: Earley-Boyer V8 test file, modified to run without run harness.

Run the testcase:
asc -import builtin.abc -in base.as earley-boyer.as


Attempting to run the earley-boyer v8 javascript test in tamarin causes the following error:

VerifyError: Error #1030: Stack depth is unbalanced. 1 != 2.

Unfortunately I have been unable to isolate the issue to a simple testcase.
(Reporter)

Comment 1

10 years ago
Created attachment 347408 [details]
base.as: util file to run earley-boyer
(Reporter)

Updated

10 years ago
Attachment #347408 - Attachment description: util file to run earley-boyer. → base.as: util file to run earley-boyer
(Reporter)

Updated

10 years ago
Attachment #347408 - Attachment mime type: application/x-download → text/plain
(Reporter)

Updated

10 years ago
Attachment #347407 - Attachment description: Earley-Boyer V8 test file, modified to run without run harness. → earley-boyer.as: Earley-Boyer V8 test file, modified to run without run harness.
Attachment #347407 - Attachment mime type: application/x-download → text/plain
(Reporter)

Comment 2

10 years ago
Created attachment 347410 [details]
Full stack trace of VerifyError
(Reporter)

Updated

10 years ago
Flags: in-testsuite?
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Comment 3

10 years ago
Jeff, can you take a look at this?
Assignee: nobody → jodyer
Status: NEW → ASSIGNED
Flags: flashplayer-qrb? → flashplayer-qrb+
Priority: -- → P3
Target Milestone: --- → flash10.x
(Assignee)

Comment 4

9 years ago
Tracking in https://bugs.adobe.com/jira/browse/ASC-2222. Closing here.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

9 years ago
Flags: in-testsuite?

Comment 5

8 years ago
Issue still exists with latest asc.jar downloaded from mozilla; this bug needs to remain open until the problem is fixed.  (It's not clear that asc.jar has been updated for some time - stale?)

Reopening and raising priority.

The JIRA tracker bug is closed for reasons not understood; the bug appears not to be fixed.
Status: VERIFIED → REOPENED
Priority: P3 → P2
Resolution: INVALID → ---
Target Milestone: flash10.1 → flash10.2

Comment 6

8 years ago
Also fails with the latest ASC code from the public SVN (latest log update there appears to be 2010-05-19).

Updated

8 years ago
Whiteboard: ASC-dependency

Comment 7

8 years ago
Further findings.

The latest ASC appears to fix this problem after all, woohoo!

However, that fix is not observable because both the v8 and v8.5 early-boyer sources are incorrect.  The v8.5 sources appear to be fixable (and cleanup patches have been submitted on bug #585564); the v8 sources need further work.

Comment 8

8 years ago
The v8 issue is now tracked by bug #585586.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Flags: flashplayer-bug+
You need to log in before you can comment on or make changes to this bug.