l10n repackages drop when a buildbot reconfig happens on production-1.9

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: armenzg, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

We have to use the new setup for l10n repackages that is being used for hg on buildbot 0.7.9.

Check how I removed the BuildL10n logic (which is not used anymore) in this attachment:
https://bugzilla.mozilla.org/attachment.cgi?id=347383&action=edit
(Reporter)

Updated

10 years ago
Blocks: 464171
(Reporter)

Updated

10 years ago
No longer depends on: 464151
(Reporter)

Comment 1

10 years ago
When we call L10nMixin inside of NightlyL10n we do it incorrectly and the patch in bug 464161 fixes it

Added dependency of bug 464151 that was removed incorrectly
Depends on: 464151, 464161
Component: Release Engineering → Release Engineering: Future
(Reporter)

Comment 2

10 years ago
The problem is already fixed on "buildbotcustom/l10n"

Why is it going to be futured? Are we not upgrading to 0.7.9?

All we need for this to be fixed is:
1) to upgrade
2) comment 4 lines in the master.cfg (the 4 lines that use BuildL10n)
3) wait for bug 464161 to be resolved (which is almost there)

The bulk of this bug is to do the upgrade to 0.7.9
Component: Release Engineering: Future → Release Engineering
(Assignee)

Updated

10 years ago
No longer depends on: 464161
(Assignee)

Updated

10 years ago
Assignee: nobody → ccooper
Priority: -- → P3
(Reporter)

Comment 3

10 years ago
If we have upgraded production-1.9-master to 0.7.9 and buildbotcustom/l10n is up to date then this bug is fixed.

Any work left is to fix bug 467196
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.