Closed Bug 464243 Opened 14 years ago Closed 14 years ago

Firefox should support onmousewheel event

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 111647

People

(Reporter: wayfarer3134, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Firefix should support the onmousewheel event like IE, Opera and Safari all do.  No, it isn't in the standards but sometimes it is preferable to declare event listeners declaratively rather than programatically, and not having onmousewheel declarative support means one can't do that consistently.

Reproducible: Always

Steps to Reproduce:
1.Declare an element like <div onmousewheel="alert('Hello mouse wheel.');" style="width:100%;height:100%;" />
2.Mousewheel on the div - you should see the alert
3.
Actual Results:  
No alert is shown.

Expected Results:  
Alert is shown.

According to:
http://www.quirksmode.org/dom/events/index.html
This is supported for IE 6,7, buggy in IE 8, Opera, Safari.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 111647
You need to log in before you can comment on or make changes to this bug.