Closed Bug 464247 Opened 12 years ago Closed 12 years ago

thunderbird trunk nightly w32 buildsymbols broken on comm-central so no useful breakpad report - Thunderbird parts of symbols missing at http://symbols.mozilla.org/thunderbird

Categories

(MailNews Core :: Build Config, defect)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b1

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [probably fixed, check nightlies on 19th])

after checking of Mac patch attachment 344484 [details] [diff] [review] on 2008-10-29 Bug 450485, no w32 buildsymbols at http://symbols.mozilla.org/thunderbird

symbols http://symbols.mozilla.org/thunderbird/thunderbird-3.0b1pre-WINNT-20081029044529-symbols.txt

no symbols http://symbols.mozilla.org/thunderbird/thunderbird-3.0b1pre-WINNT-20081031031458-symbols.txt
and henceforth to 
http://symbols.mozilla.org/thunderbird/thunderbird-3.0b1pre-WINNT-20081110032410-symbols.txt

note the last item has 
js.pdb/D5011838939644AA9A2E2EAC92D6D2301/js.sym
js.pdb/D5011838939644AA9A2E2EAC92D6D2301/js.pdb
which the others dont' have but I don't think it's related (iirc I saw that the js people were looking to get symbols)
Flags: blocking-thunderbird3.0b1?
missing are
mozmapi32.pdb/DDF12A7D37254906B2F6A9D159F835112/mozmapi32.sym
mozmapi32.pdb/DDF12A7D37254906B2F6A9D159F835112/mozmapi32.pdb
mapiproxy.pdb/1D623D3546D2499294E6D5C7C4FD159B4/mapiproxy.sym
mapiproxy.pdb/1D623D3546D2499294E6D5C7C4FD159B4/mapiproxy.pdb
thunderbird.pdb/CCABCBE989BD47578CED7C965C5073F41/thunderbird.sym
thunderbird.pdb/CCABCBE989BD47578CED7C965C5073F41/thunderbird.pdb
wsenable.pdb/6AD37BB471EB40C28B3CCB495039C6502/wsenable.sym
wsenable.pdb/6AD37BB471EB40C28B3CCB495039C6502/wsenable.pdb
Summary: thunderbird trunk nightly w32 buildsymbols broken on comm-central so no useful breakpad report - symbols missing at http://symbols.mozilla.org/thunderbird → thunderbird trunk nightly w32 buildsymbols broken on comm-central so no useful breakpad report - Thunderbird parts of symbols missing at http://symbols.mozilla.org/thunderbird
My understanding is that the breakpad reports will be useful once the symbols are added, even if the breakpad report was submitted before...if that's the case, this wouldn't need to block b1, though we would like to see it fixed asap.
Are you saying we will, if it doesn't make the train, generate symbols for 3.0b1 release builds for crash-stats after the fact?

This also frustrates topcrash reporting, b/c the stacks don't aggregate.
gozer will know for sure...
Gozer, if no sure-fire solution is immediately in sight and http://hg.mozilla.org/comm-central/rev/5709136d4b9c is the proximate cause, then I'd like to see that checkin backed out.  Banking on ability to get w32 stacks "later" I think is not the optimal option, because even if it works, in the mean time we greatly reduce our ability to QA our largest platform.
I wonder how we even had symbols before that patch you point out because it should have been solving exactly this issue of missing symbols, IIRC...
Flags: blocking-thunderbird3+
Target Milestone: --- → Thunderbird 3.0b1
Gozer, are you the right person to own this bug? If so, can you assign it to yourself, and put in some sort of ETA for a fix? thx!
Another thought if favor of backing out bug 450485 quick - if it's sure to workaound the w32 issue - is we can use the freeze delay to crack some top crashers ... which would be *really* nice for eventual b1 users.  And then shoot for the total solution after b1 ships.  Takes the pressure off everyone, although admittedly hurts Mac-only crashes.
The fix for bug 450485 is indeed responsible for this regression.
This should now be resolved, with the latest push from bug 450485.  Waiting for tonight's nightlies before closing this bug.
Flags: blocking-thunderbird3.0b1?
Whiteboard: [probably fixed, check nightlies on 19th]
From last night's builds:

http://symbols.mozilla.org/thunderbird/thunderbird-3.0b1pre-WINNT-20081119032441-symbols.txt

We got symbols again, including the ones that vanished:

mozMapi32.pdb/E641DE00F9E242479587C014A02B2FFB1/mozMapi32.sym
mozMapi32.pdb/E641DE00F9E242479587C014A02B2FFB1/mozMapi32.pdb
MapiProxy.pdb/F2AC70951C2E4298885383A7533E43241/MapiProxy.sym
MapiProxy.pdb/F2AC70951C2E4298885383A7533E43241/MapiProxy.pdb
thunderbird.pdb/E788F86BEFA548899CEFB19A98387F791/thunderbird.sym
thunderbird.pdb/E788F86BEFA548899CEFB19A98387F791/thunderbird.pdb
WSEnable.pdb/1171D73282E54A1EBD652C1CBD7CCE971/WSEnable.sym
WSEnable.pdb/1171D73282E54A1EBD652C1CBD7CCE971/WSEnable.pdb
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
v. - ref Bug 450485 comment 25
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.