Image corruption on NoScript logo with gfx.color_management.mode = 1

RESOLVED DUPLICATE of bug 455169

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 455169
10 years ago
10 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
Created attachment 347679 [details]
testcase 1: NoScript logo

STEPS TO REPRODUCE:
 1. In about:config, set gfx.color_management.mode to 1
 2. Restart Firefox
 3. Load URL (or upcoming testcase)

ACTUAL RESULTS: 
  Right 1/4 of the image is corrupted (see upcoming screenshot)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081111 Minefield/3.1b2pre
Flags: blocking1.9.1?
(Reporter)

Comment 1

10 years ago
Created attachment 347680 [details]
testcase 2: FlashGot Logo
(Reporter)

Comment 2

10 years ago
Created attachment 347681 [details]
screenshot of corruption on testcase 1

Fun fact: though it's kind of hard to see, the favicon shows the corruption, too.
(Reporter)

Comment 3

10 years ago
Created attachment 347682 [details]
screenshot of corruption on testcase 2

it's easier to see the corrupted favicon in this one, btw.
(Reporter)

Comment 4

10 years ago
FWIW: I found this bug using Ubuntu 8.10.  And I can reproduce it on two different machines -- my laptop & desktop.
Looks like some weird interlacing bug. CCing glenn.

I seem to remember seeing something like this somewhere else when we turned on CMS but it was when I was in Argentina and I wasn't keeping that great track of things.

Glenn - any ideas?
Blocks: 455056

Comment 6

10 years ago
Isn't this the same as bug 455169 ?
(Reporter)

Comment 7

10 years ago
Yup, looks like it, based on attachment 338467 [details].

Thanks philippe!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455169
Flags: blocking1.9.1? → blocking1.9.1+
You need to log in before you can comment on or make changes to this bug.