Problem loading page - Error: "the connection has timed out"

VERIFIED WORKSFORME

Status

support.mozilla.org
Knowledge Base Articles
VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Mark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

When working at home last night I couldn't browse on my laptop using Firefox (IE7 and Safari worked fine), although my wife, connecting through the same wireless network was using Firefox without problems.
I tried online chat with zzxc (http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_parentId=204451#threadId204500) who wasn't able to help resolve the matter.
This morning, using the same laptop hard-wired into my company network, Firefox worked fine. However, it wouldn't work if I disconnected and tried our Office Wireless Network.

Solution was to change the Firefox proxy connection settings.

I have searched the knowledge base this morning and not found a similar report. Therefore I have logged on to make the suggestion that this simple solution should be in the KB or FAQ's

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Component: General → Knowledge Base Articles
Product: Firefox → support.mozilla.com
QA Contact: general → kb-articles
This is documented in this knowledge base article: http://support.mozilla.com/en-US/kb/Firefox+cannot+load+web+sites+but+other+programs+can#Connection_settings

In this case, it seems you had configured it to use an internal proxy server only available on your work connection.  If a connection is refused or the address is invalid, this will result in a "Proxy server connection" error.  If the connection times out, however, the error message does not specify a proxy server.  There is already a bug to change this message to be correct - bug 197697.

Since there is already a knowledge base article that covers this, I am marking this bug "works for me."  I will change that knowledge base article to mention the "connection timed out" error specifically as a problem that can be caused by proxy servers, to make it easier for people to find this solution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
v
Error message added. <http://support.mozilla.com/tiki-pagehistory.php?page=Firefox+cannot+load+web+sites+but+other+programs+can&compare=1&oldver=14&newver=15&diff_style=sidediff>
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.