UI:Account Wizard:Summary Panel: show summary of all settings

VERIFIED FIXED in mozilla0.8

Status

SeaMonkey
MailNews: Account Configuration
P2
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: jglick, Assigned: racham)

Tracking

({polish})

Trunk
mozilla0.8
x86
Windows 98
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(14 attachments)

(Reporter)

Description

18 years ago
Account Wizard: Summary Panel(Congraduations panel). Show a summary of all 
the account settings the user has selected.

Priority 5. Polish.
(Reporter)

Updated

18 years ago
Keywords: nsbeta3, polish
Target Milestone: --- → M18

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 1

18 years ago
Mail triage is marking nsbeta3-
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 2

18 years ago
massive reassign of account manager bugs -> sspitzer
please feel free to put me back on the CC if you have any questions/comments
Assignee: alecf → sspitzer

Comment 3

17 years ago
I checked the spec and I don't see specifically what information should be
displayed for the following:
- POP/IMAP
- Netscape Webmail
- AOL
- News

For News I would like to see:
- Username
- Email address
- News Server Name

Comment 4

17 years ago
Adding mail3 as a keyword. Giving the user a summary of all the information is
good. This allows them to go back if a mistake was made and could be a
reinforcement that they entered the information correctly.
Keywords: mail3
about news, we should not be showing the username.
we have a related bug about showing the username for news in the account manager.

the problem is the username (and password) we actually use is stored in the
password manager.  news usernames can vary per newsgroup on a server, so we
store it on a group by group basis (and for the server.)


Comment 6

17 years ago
Thanks for clarifying the news issue.

Comment 7

17 years ago
markings nsbeta1+ and moving to mozilla0.8.  reassigning to racham.
Assignee: sspitzer → racham
Keywords: nsbeta3 → nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta3-] → [nsbeta1+]
Target Milestone: Future → mozilla0.8
(Assignee)

Comment 8

17 years ago
I have added code to enable the display of most of the information we collect
from the user as a Summary on the last screen of Account Wizard.

I will post the patch and also attach 2 snapshots taken after creating a mail
and news accounts respectively.

As we are using trying to hide the fields where we do not have data or the
fields not relavant in the context, on the summary panel of mail/news account
you will find a blank line(s) separating some of these items. Snapshots included
hopefully are in reasonable shape for presenting the info to the user. Anyway,
input and ideas are welcome here.

Adding seth, bienvenu and ninoschka to the cc list. Jennifer has reported this bug.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

17 years ago
Created attachment 21232 [details] [diff] [review]
patch to display account wizard summary
(Assignee)

Comment 10

17 years ago
Created attachment 21233 [details]
snapshot#1 - mail account
(Assignee)

Comment 11

17 years ago
Created attachment 21234 [details]
snapshot#2 - news account
(Assignee)

Updated

17 years ago
Keywords: patch
comments:

notice the "..." in your screen shots.  My guess is the text is getting cropped,
so layout puts the "..." in there.

the problem is with your new entities in aw-done.dtd

you have:
+<!ENTITY serverTypePrefix.label "Incoming Server Type:      ">
+<!ENTITY serverNamePrefix.label "Incoming Server Name:      ">
+<!ENTITY smtpServerNamePrefix.label "SMTP Server Name:">
+<!ENTITY newsServerNamePrefix.label "News Server Name:      ">
you should have:
+<!ENTITY serverTypePrefix.label "Incoming Server Type:">
+<!ENTITY serverNamePrefix.label "Incoming Server Name:">
+<!ENTITY smtpServerNamePrefix.label "SMTP Server Name:">
+<!ENTITY newsServerNamePrefix.label "News Server Name:">

it looks like the xul is already written to line things up correctly.

also, what do pop, webmail and AOL accounts look like?  
can you post screen shots for your local commercial build?

I'm guessing that imap, webmail and AOL accounts will say "Incoming Server Type:
imap" and pop will have "Incoming Server Type: pop3"

I think we should have:

IMAP (instead of imap)
POP3 (instead of pop3)
AOL Mail (instead of imap)
Netcenter WebMail (instead of imap)

once you fix the "..." problem, r=sspitzer. 

then, open a new bug on allowing for a pretty name for the type.  I've got some
ideas on how to do that I'll discuss with bhuvan.
*** Bug 37602 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 14

17 years ago
>I think we should have:

>IMAP (instead of imap)
>POP3 (instead of pop3)
>AOL Mail (instead of imap)
>Netcenter WebMail (instead of imap)

I agree.

I would expect POP3 to look almost identical to IMAP (except for Incoming 
Server Type of course).  AOL and Webmail would look similar to Mail accounts 
except Incoming and SMTP Server Names are not needed since the user didn't enter 
these themselves (and hence may confuse them).  Incoming Server Type: "AOL Mail 
- IMAP" or "Netcenter Mail - IMAP".  (" - IMAP" can be left off if folks think 
that is better).
I've logged #63775 to track the other issue.  (cleaning up the summary for AOL
accounts and Netcenter WebMail accounts.)

(Assignee)

Comment 16

17 years ago
With some more polish on display after discovering the ability to collapse
unwanted rows and manage between distance columns, I have new screenshots and
the patch to post.

Starting with screenshots..please ignore previous postings.
(Assignee)

Comment 17

17 years ago
Created attachment 22180 [details]
IMAP mail account screenshot
(Assignee)

Comment 18

17 years ago
Created attachment 22182 [details]
POP3 Mail Account screenshot
(Assignee)

Comment 19

17 years ago
Created attachment 22183 [details]
News Account screenshot
(Assignee)

Comment 20

17 years ago
Created attachment 22184 [details]
ISP (AOL) Mail Account screenshot
(Assignee)

Comment 21

17 years ago
Created attachment 22185 [details]
ISP (Webmail) Mail Account screenshot
(Assignee)

Comment 22

17 years ago
Created attachment 22186 [details] [diff] [review]
mozilla mailnews patch
(Assignee)

Comment 23

17 years ago
Created attachment 22187 [details] [diff] [review]
ns mailnews patch
(Assignee)

Comment 24

17 years ago
Seth, Scott/Bienvenu,

Please go through the patches posted and provide r= and sr=.
They are slightly modified frommy previous postings. They are simple and
shouldn't consume much time.

thanks
bhuvan
r=sspitzer

1)  I wouldn't check in your ns tree change without checking the spec.  that
will give all new aol accounts the pretty name of "AOL Mail".  double check with
kmurray, nbaca, jglick.  (I know we do that for "Netcenter Web Mail", but AOL
Mail might be different on purpose.)

2) no need to log that other bug, it looks like I did it already: #63775

Comment 26

17 years ago
As far as I know the pretty names are:

- AOL Mail
- Netscape Webmail
(Assignee)

Comment 27

17 years ago
Adding Kevin to the cc list.
so we are supposed to show "AOL Mail" in the folder pane by default?

if that is the case, your change to the ns tree is correct and will fix that
problem.

Comment 29

17 years ago
+        if (accountName == "")
and similar
=> if (!accountName)
+    if (userName == "" && email != "") {
=> if (userName && !email) {

!     if (!value || value =="") {
!     if (!value) {

Also, disabled items shouldn't be defaults (Next is disabled and default in one 
of the pictures) if you don't want to fix that here, could you file a bug for 
it?

Comment 30

17 years ago
The screen shots look excellent. Two things:
1. Regarding nbaca's comment on 1/9 at 16:26, the "pretty name" for webmail is
"Netscape WebMail" (note the capitalized M), and is wrong in the folder pane as
well (I know, file a bug)
2. On the AOL summary screen(id 22184), we need to slim down the info. "User
Name" should be "Screen Name" and we should remove the following lines/info:
"Incoming Server Name," "Incoming Server Type," and "SMTP Server Name."  Why?
You know why. Because AOL users won't care about that info.
(Assignee)

Comment 31

17 years ago
Created attachment 22208 [details] [diff] [review]
aw-done.js diffs updated with timeless comments
(Assignee)

Comment 32

17 years ago
Kevin,

Regd the first issue you brought up..it's pretty easy to fix 'Webmail' to
'WebMail'. I can do that along with this fix.

Regd your second issue, I would like tackle that in a separate bug which need to
be filed in bugscape (not in bugzilla).

Question posed by Seth about 'AOL Mail' still remains unanswered about 'Aol
Mail' as the pretty Account name on Aol screenshot. I guess you implied that it
is OK to have prettyname 'AOL Mail' for aol accounts. But I want to confirm on
that one explicitely so that we don't overwrite some existing behavior
accidentally..Please comment on that.

Comment 33

17 years ago
does this change make it so that all aol mail accounts show up in the folder
pane as just "AOL Mail" and not Mail for joe@aoo.com? That would mean that if I
had multiple AOL accounts, they would all show up as just AOL Mail and I could
not tell the difference between the accounts. That would be very confusing for me.

Comment 34

17 years ago
I think Seth was just asking about the default, which should be rename-able.
(Reporter)

Comment 35

17 years ago
Screen shots look good. Some comments.

News summary screen: Do we want to show "User Name"?  I remember some comment 
about not showing it. Maybe a comment from Seth?

Agree with Kevin about AOL Mail and WebMail summary screens. They shouldn't show 
all that info. Only the info that the user actually entered or needs to know.

AOL: Email address, Account Name.  (Screen Name - the wizard currently asks 
users to enter their email address, but they are really only entering their 
screen name since the static text '@aol.com' is shown.  Could the wizard ask 
users to enter their screen name instead since that is more accurate?  If so, 
then also show "Screen Name" on the summary page.)

WebMail: Email Address, Account Name.  ("Screen Name" or "User Name"?  same 
comments as above, but does netcenter call it a User Name or a screen name?  
The wizard should also be changed to ask for User/Screen Name instead of email 
address since that is what the text field is asking for).

Comment 36

17 years ago
We need to change the wizard to ask for "Screen Name" as well. Regarding
WebMail, they use "User Name."
(Reporter)

Comment 37

17 years ago
I updated the Account Wizard screens of the Account Settings spec. It doesn't 
show up yet, but should be available soon.

http://www.mozilla.org/mailnews/specs/accounts/

Note: red text for aol and webmail screens is what I would like to see the 
wording changed to.
yes, jglick is right.  don't show the username for news.

but feel free to log that as a bug and fix it later, along with the other polish
items.

Comment 39

17 years ago
Jen, did you mean to change the wording on the WebMail screen back to Netcenter?
(Reporter)

Comment 40

17 years ago
Kevin, what should it say?  "Enter you WebMail user name?".  Let me know what 
the correct wording is and i'll update the spec.  Thanks.

Comment 41

17 years ago
Good question - since it's no longer called "Netcenter" we should probably call 
it "Netscape.com User Name." 
(Assignee)

Comment 42

17 years ago
Here is an updated patch after our discussions.

* News account summary panel will not have username.

For all AOL and WebMail issues, please refer to bugscape bug 3674.

New patch coming up..
(Assignee)

Comment 43

17 years ago
Created attachment 23048 [details] [diff] [review]
New mailnews summarypanel diffs
(Assignee)

Comment 44

17 years ago
Created attachment 23049 [details]
New news screenshot
(Assignee)

Comment 45

17 years ago
Created attachment 23050 [details]
New ISP (AOL) screenshot just to show all of you about the customized summary panel based on isp rdf file data

Comment 46

17 years ago
ok racham, what's the *real* bugscape number? ;-)
(Assignee)

Comment 47

17 years ago
It is 3674...
Here you go : http://bugscape.netscape.com/show_bug.cgi?id=3674

Comment 49

17 years ago
sr=bienvenu. However, I still have to say that just showing AOL Mail in the
folder pane without indicating the user/screen name is going to be very
confusing for AOL users with multiple e-mail names. This is a very common useage
- a family shares an AOL account, and has separate e-mail accounts for each
member. We would be requiring them to have separate netscape profiles in order
to distinguish between their aol accounts (because they would all just show up
as "AOL Mail" in the folder pane), and I believe that setting up separate
profiles is a very difficult thing to require AOL users to do. I thought we were
trying to get away from setting up separate profiles.
bienvenu, racham, and jglick: 

instead of "AOL Mail" for every aol account, how about "AOL Mail for
<screenname>.

we should allow racham to land his patch (to get it out of his tree) and then
log a new bug to fix that issue.
(Assignee)

Comment 51

17 years ago
I am going to do 'AOL mail for <screenname>'. That is the plan. I will file a
new bug. Just didn't bring that up here. I don't want to delay this furher.
Thanks for review and superreviews.
(Reporter)

Comment 52

17 years ago
I think "AOL Mail for <screenname>" is good, as well as "WebMail for
<username>". We had talked about "AOL Mail for <emailaddress> at the issues 
meeting, but I thought that was too long and actually did what Seth suggested in 
the spec.

http://www.mozilla.org/mailnews/specs/accounts/images/WizardAol6.gif
(Assignee)

Comment 53

17 years ago
We will go with just the screenname/username (ISP's user's email id).

I already open a bug (http://bugscape.netscape.com/show_bug.cgi?id=3709) on this
issue. thanks.
(Assignee)

Comment 54

17 years ago
Fixed.

Thanks for reviews/super reviews && suggestions.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 55

17 years ago
Build 2001-02-19-08: NT4, Linux RH 6.2, Mac 9.04
Verified Fixed.
Status: RESOLVED → VERIFIED

Comment 56

17 years ago
These are samples of what was displayed.

POP/IMAP Summary:
Account Name:         qatest20@netscape.com
User Name:            qatest20
Email Address:        qatest20@netscape.com
Incoming Server Name: nsmail-12
Incoming Server Type: POP3/IMAP
SMTP Server Name:     nsmail-12

News Summary:
Account Name:     zia
Email Address:    qatest20@netscape.com
News Server Name: zia
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.