Current version of Java plugin not detected, although installed

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
minor
RESOLVED WONTFIX
9 years ago
9 months ago

People

(Reporter: Thomas Hedden, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12

If an old version of Java has been installed, and then the current version is installed, the new version is not always automatically detected by the browser when you visit the Java website (http://www.java.com) and follow the instructions to detect what version of Java is installed.

Reproducible: Always

Steps to Reproduce:
1. Start with a Seamonkey installation and an old Java installation.
2. Uninstall Seamonkey.
3. Download a new version of Seamonkey and do a clean install to a new directory.
4. Download and install the current version of Java.
5. Close and restart Seamonkey.
6. Go back to the Java website, and follow the procedure to detect the current version of Java.
7. Open Internet Explorer, visit the Java website, and follow the procedure to detect the current version of Java.
Actual Results:  
Seamonkey detects the OLD version of Java, although the new version has been installed. Internet Explorer detects the NEW version of Java.

Expected Results:  
Seamonkey should detect the NEW version of Java, just as Internet Explorer does.

I had this problem repeatedly, and at first I (mistakenly) assumed that the Java folks had abandoned Windows 2000. After having been set straight about that, I tried tracking down the problem, and found this article:
http://kb.mozillazine.org/index.php?title=Java&redirect=no
The section "Remove outdated Java files from the browser plugins folder" says that plugin files should NOT be put in the browser's plugins folder. I checked, and there were no such files there, since I had a clean install to a new directory, following an uninstall of the previous version. However, if you scroll down to the section "Workaround if Java is not detected - Advanced", it says that if the plugin is not detected, you can copy the files <java_path>/bin/np<*>.dll to the browser's plugins folder. I tried this, and after I did this, the browser WAS able to detect the current version of Java.
Possibly related to this is the fact that if you open the Java Control Panel (Settings | Control Panel | Java) and click on the Advanced tab, and then expand the tree "Default Java for Browsers", the "Mozilla family" check box won't stay checked. This was still true even after I finally got the browser to recognize the current version of Java.
I also wonder whether this might be related to bug 123315.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081115 SeaMonkey/2.0a2pre - Build ID: 20081115000503

Works for me on Linux (I had an obsolete version of Java, followed exactly the install procedure described on the Java site, and after restarting it detected the latest version).

Notes:
- Steps 2 and 3 (uninstall/reinstall SeaMonkey) are not necessary.
- Gecko browsers (Netscape, SeaMonkey, Firefox...) don't use the same plugins as Internet Explorer. They won't recognise IE plugins, nor will IE recognise Gecko plugins (sometimes called Netscape plugins). IOW, Java can be installed for IE but not for SeaMonkey, or vice-versa.
- If you set the preference plugin.expose_full_path to true in about:config, the about:plugins page will tell you exactly where each plugin was found. This might help you uninstall obsolete versions.
Component: General → Plug-ins
Product: SeaMonkey → Core
QA Contact: general → plugins
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

9 years ago
The point is that even when the instructions are followed
for installing the new version of Java on a clean install
of the latest release of Seamonkey, Seamonkey does not
automatically detect the new version of Java that has just
been installed (at least on the W2K platform), while IE does
detect it. It should not be necessary to uninstall the old
version of Java unless the instructions for Java call for
that, which they don't. This could be a bug in the Java
installer rather than in Seamonkey, but one way or the other
Seamonkey is not doing something that IE does, and post-install
tweaking is necessary to get it to see the new version of Java.
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.