Closed Bug 464566 Opened 11 years ago Closed 11 years ago

judas.df.lth.se mirror doesn't have latest Firefox 3 for Linux

Categories

(Release Engineering :: General, defect, minor)

All
Other
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: myk, Unassigned)

Details

I tried to download Firefox 3.0.3 for Linux from getfirefox.com today, and I was redirected to a "404 - Not Found" page at the following URL:

http://judas.df.lth.se/mozilla//firefox/releases/3.0.3/linux-i686/en-US/firefox-3.0.3.tar.bz2

Traveling up the path, it looks like it does have 3.0.4:

  http://judas.df.lth.se/mozilla//firefox/releases/ :

  3.0.4/	2008-Nov-12 06:58:33	-  	Directory
  3.1b1/	2008-Oct-15 00:11:03	-  	Directory
Likely cause for this is 3.0.3 getting removed from the "check this every pass" list in the sentry config" when 3.0.4 was added, so when 3.0.4 replaced 3.0.3 on the mozilla-current mirrors, sentry didn't pick up that 3.0.3 was gone yet.
Assignee: server-ops → nobody
Component: Server Operations → Release Engineering
QA Contact: mrz → release
Could be the request happened between updating the rsync config from 3.0.3 to 3.0.4, and sentry coming along to disable the mirror.
Dave, do we have any data on how long a "Check Now" sentry run takes ? It might be a problem for releases if it takes (roughly) twice as long by checking both the previous and current release.
Last time I was paying attention it was taking about a half hour to run.
The latest is now FF3.0.4. I've just verified that http://judas.df.lth.se/mozilla//firefox/releases/3.0.4/linux-i686/en-US/firefox-3.0.4.tar.bz2 does work fine. And the site correctly does not have any FF3.0.3.

Not sure if this was caused by bug#466641 or not, but I'm closing as WORKSFORME.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Dave is really asking for a process change here - in bouncer, we should not remove the Check Now bit on the current release when adding entries for a new one. We should wait for a while (a day?, a few hours) when something is removed from the mozilla-current rsync module (/pub/mozilla.org/zz/rsyncd-mozilla-current.exclude) before revoking Check Now. 

I'll update our wiki docs for this, and we'll see if sentry completes quickly enough on the next release.
Yes, that's correctly what I was asking for.  Sentry needs to keep scanning for the file you just removed until it detects that it's been removed in order to avoid 404s with people getting sent to the mirrors that just replaced it with 3.0.4 because it hasn't figured out that they don't have 3.0.3 yet until the overnight check everything pass runs.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.