Closed Bug 464577 Opened 14 years ago Closed 7 years ago

Re-enable autodetection mechanism for work offline

Categories

(Core :: Networking, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1134596

People

(Reporter: laurent, Unassigned)

References

(Blocks 2 open bugs)

Details

It seems that the offline/online status does not change in the browser (at least FF 3.1b1 and the trunk), when the computer is connected/deconnected to a network.

I tested with this test case https://bugzilla.mozilla.org/attachment.cgi?id=220609 and I also verified the menu item "work offline" in the File menu.

It works fine in Firefox 3.0  (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4)

But it does not work in FF 3.1b1 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1) and the nightly of firefox (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081112 Minefield/3.1b2pre). If the computer is not anymore connected, the item "work offline" stays unchecked, and the document of the test case doesn't receive the offline event (nor online event if the computer is reconnected).

Note: in all case, I'm using binaries from Mozilla, not from my distro (ubuntu 8.05), and the issue appears even if I use the same profile or a different profile for each version.
Could be because NM is now disabled by default on trunk (bug 424626). Check the value of the toolkit.networkmanager.disable config option.
If I turn toolkit.networkmanager.disable to false, it works. Thank you Sylvain :-)

I think a checkbox should be displayed on the network panel of the preferences dialog, to change this pref.
Keywords: regression
Summary: Offline status does not change → Offline status does not change due to toolkit.networkmanager.disable defaulting to true
Hm, with TB3.0.1 and FF3.6 (Fedora 12 packages), the config value is false, but no matter what the value (tested true/false in both TB and FF), when I disconnect from the router, the applications don't notice.
Should another bug report be opened or am I at the right place?
It works well on the last Ubuntu here. If I set toolkit.networkmanager.disable to false, online/offline events are fired when the gnome NetworkManager goes online/offline.

Any good reason to keep this feature disabled?
Ok, actually, there is a good reason: bug 424626
Bug 424626 has been already fixed so we can reconsider it.
Hm, Bug 424626 seems to be still in the "NM disable state". But at least bug 627672 (link detection) is fixed now.
Blocks: 391732
The preference toolkit.networkmanager.disable does not even exist anymore, and yet this bug is still open - and Firefox (version 28) still does not automatically enter offline mode when I disconnect from the wireless network. Did the pref just become renamed, or is this bug invalid and I am experiencing another problem?

(setting offline.autoDetect in Thunderbird fixed the issue there, at least - but that option does not seem to exist for Firefox?)
There's a manage-offline-status pref these days - that mostly defaults to false, but I want to remove this in my work with bug 939318
For the reference, the offline auto-detection was turned off in bug 424626 on Linux (for 3.0.1) and bug 620472 on other platforms (for 4.0) because it didn't work correctly.

There's a lot of arguments for and against this in bug 565564 and others.
Summary: Offline status does not change due to toolkit.networkmanager.disable defaulting to true → Re-enable autodetection mechanism for work offline
Duplicate of this bug: 438842
Duplicate of this bug: 987802
Duplicate of this bug: 1079113
Blocks: 565564
(In reply to Nickolay_Ponomarev from comment #10)
> For the reference, the offline auto-detection was turned off in bug 424626
> on Linux (for 3.0.1) and bug 620472 on other platforms (for 4.0) because it
> didn't work correctly.

That's many years ago, it's well possible that NetworkManager got more reliable in the mean time.
My personal Firefox experienced has benefited *a lot* from enabling this auto-detection. Instead of downloads being lost when I have to send my laptop to stand-by urgently, they are continued properly. Instead of waiting for up to 1 minute after the wireless connection is established, until Firefox finally notices this (not sure if it takes so long to fetch the new DNS servers, or whatever), I'm back online instantly. (Similar for Thunderbird, where I don't have to manually toggle offline/online anymore to be notified about new incoming mail - the kind of silent failure where it just dropped the connection was really annoying.)
The handling of network changes is not the same as handling offline though, and it seems like you're describing that and not true offline (disregarding that the exact definition of offline is tricky). Bug 939318 introduced the frame work for dealing with new network conditions better than before. With that model (which isn't yet provided for all platforms), there shouldn't be any need to toggle offline/online anymore.
When we bring it back we should use the balloon notification like we see when we install an addon, that this page is cached. I like those notificaitons :) Or maybe bar display like the "Choose what you want to share" bar, im not sure one of the two :P
The work in bug 1134596 will allow Firefox to detect and go offline automatically without "work offline" getting set.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134596
You need to log in before you can comment on or make changes to this bug.