Date filter's date in rules.dat & display changes to a day earlier.

RESOLVED WORKSFORME

Status

MailNews Core
Filters
P3
major
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Unassigned)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using july25 commercial build Mac OS 9.0
Did not happen on linux rh6.0 or NT 4.0


When a profile is migrated from 4.x which had a message filter set to filter on
date, the date in the 6.0 rules.dat is recorded as one day earlier.

1.  In 4.x open to mail window.
2.  Edit|Message Filters.
3.  Set a filter using Date Is <today's date/default>.
4.  Exit communicator and look at the filter rules file in the Netscape Users
directory, file is named Filter Rules.  Notice the date filter's date value is
"25-Jul-2000".  
5.  Migrate the profile to 6.0, open mail window.
6.  Look at the migrated rules file named "rules.dat" located in the Server
directory in the Users50 directory.  
    Path: Users50/Laurel/Mail/nsmail-2  or  Users50/Laurel/ImapMail/nsmail-2
7.  Notice the date in the rules.dat is "24-Jul-2000".   (System date is
properly set to July 25.

Result:  date in rules.dat change for message filter based on date

Expected:  date should remain the same as it was with 4.x filter file
(Reporter)

Updated

18 years ago
Keywords: pp
QA Contact: gbush → laurel
(Reporter)

Comment 1

18 years ago
Hmmm...something is bizarre here.  If I edit the rules.dat to make it another
date, then launch 6.0, get mail and exit, when I check the rules.dat file it's
now a day earlier. So it's not migration, but definitely weird. I don't know
what's going on.
Assignee: sspitzer → alecf
(Reporter)

Updated

18 years ago
Summary: Migrated date filter shows wrong date in rules.dat → Date filter's date in rules.dat changes to a day earlier.
(Reporter)

Comment 2

18 years ago
At step 5 of my steps, I believe you need to Get Msgs before exiting and
checking the rules.dat file.  I've tried this on IMAP and POP, both get their
rules.dat changed. Augh.
(Reporter)

Comment 3

18 years ago
I did not have any problem using 4.7 with the date filters.  They worked OK, no 
change to the "Filter Rules" (POP) or "nsmail-1 Rules" (IMAP) files. 

Comment 4

18 years ago
this is bad, nominating for nsbeta3
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 5

18 years ago
Just an update/FYI:  This is still happening when migrating from 4.x -- date in
filter changes. 

Updated

18 years ago
Component: Profile Migration → Filters
OS: All

Comment 6

18 years ago
reassign all search/filter UI bugs to gayatrib, part 2
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW

Updated

18 years ago
Target Milestone: M18 → ---

Comment 7

17 years ago
reassigning to naving
Assignee: gayatrib → naving
(Reporter)

Comment 8

17 years ago
Just an update that this is still occurring (mac only) with current (trunk)
builds. It's odd, but it happens -- the date is changed.
To reiterate steps:
1.  Add a date filter, say specifying date 09/03/01. Confirm OK.  Note: if you
look at the filter again in the session, the date is fine (in both display and
in rules.dat) .
2.  Quit Netscape. 
3.  Relaunch to mail, check filter -- date is now showing as 09/02/01 in display
and in rules.dat.
Summary: Date filter's date in rules.dat changes to a day earlier. → Date filter's date in rules.dat & display changes to a day earlier.
this bug has not been touched since 2001-09-05, therefore this reminder.

Reporter could you please retest with a current mozilla build and let us know if
the problem is still present or the bug can be closed.
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core

Comment 11

12 years ago
do you still see this problem?
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody

Comment 13

11 years ago
This bug has rotted, rules.dat is no longer used.  msgFilterRules.dat is the replacment file name. The reporter is no longer employed by AOL Netscape.

Comment 14

11 years ago
David, any reason to believe this bug still exists?

Skimming a reasonable bug query I did not find any bugs that likely addressed this issue.  So despite the age and change in file name the question remains, tho it seems likely, whether this still happens on MAC.
Keywords: 4xp
QA Contact: laurel → filters

Comment 15

11 years ago
no, I"m happy to mark this wfm.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.