Browser completely hangs attempting to display this URL

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Ron Gavlin, Assigned: jst)

Tracking

({hang, testcase})

Trunk
x86
Windows 2000
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Browser completely hangs attempting to display http://www.javacoffeebreak.com

Comment 1

18 years ago
Confirming.  This is a very strange crash, when you have the following (will
attatch testcase shortly) mozilla crashes:
<table><tr><td>
<script language="javascript">
document.write(" a whole bunch of text, site and testcase have 11k here ")
</script>
</td></tr></table>

now I know that you REALLY shouldn't write 11k of text in one document.write,
but I can't find any reason why it's not valid.  What's strange though is if you
have the .write by itself it works fine, but when put into a table it crashes
(why I changed to HTMLTables).
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
Keywords: crash, testcase

Comment 2

18 years ago
Created attachment 11930 [details]
Testcase

Comment 3

18 years ago
setting default owner

Comment 4

18 years ago
setting default owner
Assignee: asa → karnaze
QA Contact: doronr → desale

Comment 5

18 years ago
I've tried it (it indeed crashes Moz.)
But when I replace the testcase with document.writeln( <100K of text here>)
there's no problem..
I'll try to narrow the testcase down a bit

Comment 6

18 years ago
Is this W2K only? DOES NOT crash on either test case on today's pull on NT and 
Linux (RH 6.2)

Comment 7

18 years ago
Testcase and URL working fine for me too, on WinNT and Linux using 8/15 trunk 
build. 

Chris Veenboer, what platform are you testing on, and what build?

Can somebody please verify that this is still a problem on Win2000 using a 
recent daily build? Thanks.
(Reporter)

Comment 8

18 years ago
Still broken here using build 2000081708 on W2K with SP1.

Comment 9

18 years ago
Still broken using build 2000082008 on WinNT SP4..
(this build doesn't seem to display very much BTW, so it could be another 
problem)
Alas, I don't have a W2K machine to test on right now..

Comment 10

18 years ago
triaging karnaze's bug list
looks like the might not have anything to do with tables.  I don't have a Win 
95/98/2k machine to generate a stack from, but it sure looks like a DOM thing.  
Chris D. said she'd try to get a stack trace from her Win98 machine.

With Chris K. on vacation, someone needs to investigate.  jst?  vidur?

Nominating for nsbeta3, easily reproduced crasher.

Assignee: karnaze → jst
Keywords: nsbeta3

Comment 11

18 years ago
Tested on Win 98 build 08-23-08-M18. Application hangs but does not crash. 
Unable to get stack trace as Talkback is not generated.

Comment 12

18 years ago
Marking nsbeta3-.  Doesn't happen on all platforms and is a low visibility page.
Whiteboard: [nsbeta3-]

Comment 13

18 years ago
It stopped my 2000070208 Win98 and goes smoothely with my CVS 20000901 build
under Win98 so I mark this as worksforme (now).
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 14

18 years ago
Sorry, the fact that it works ok on Win98 isn't relevant.  The submitter saw the 
bug on Win2k.  Also, since this bug involves doing a large operation, it 
could easily be dependent on system configuration:  amout of RAM, size of swap 
space, etc. Unless you can really verify that it isn't a problem considering 
these variables, the bug has to stay open.

In general, please be very careful about changing the resolution of a bug.  By 
doing so, you take it off the engineering staff's radar, which means if you're 
wrong, an important problem could go without attention of a long time (until QA 
or somebody else realizes it isn't really fixed.)  The right thing to do is to 
make an annotation in the bug about your findings, and let the assigned engineer 
make a determination about what should be done.  Thanks!
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 15

18 years ago
Sorry for beeing to rapid, I have seen the same as chrisd on 0830 and I was 
just trying to produce the stack trace with my fresh build and everything was 
fine (for the first time). I tried to convince rufus@nonstuff.de to finish this 
bug.

Comment 16

18 years ago
rufus here...what you want me to finish?  I'm on win98 and wit works 100% fine
for me, so I can't narrow it down anymore...leaving since reported on w2k
(anyone got w2k to test this on?)
(Reporter)

Comment 17

18 years ago
WorksForMe with Build 2000090408 on W2K SP1. 
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
I tried this one on Win-95 and crashes on load completely.
If you don't see it first time, try to reload 2-3 times. It crashes.

Reopening bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 19

18 years ago
I think this bug needs a little QA and cleanup.  desale, can you determine which
Win platform(s) this crash occurs on?  I can't get it to happen on NT4 at all.
The bug says the original report was Win2k.  You say you can repo on Win95.
Rufus and Ron claim WFM on Win2k and Win98 respectively.  We need to straighten
this out so jst doesn't waste any time trying to fix this on the wrong platform.
 And we have very little time left, so the sooner the better!
Thanks!
(Reporter)

Comment 20

18 years ago
Indeed, on Win2K, browser hangs after 2nd or 3rd page reload.

Comment 21

18 years ago
Can't dup on my W2K-JA.  As per instruction, I reloaded few times.  Doesn't 
hang nor freeze.  Works for me. Need more info.

Updated

18 years ago
Keywords: crash → freeze
(Reporter)

Comment 22

18 years ago
Using build 2000121708 WORKSFORME
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Updated

18 years ago
Keywords: freeze → hang

Comment 23

18 years ago
marking verified using the 2000122904 build on win2k. Jesse on #mozillazine 
couldn't get it to crash or hang on win98 with the latest build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.