Closed Bug 464727 Opened 13 years ago Closed 13 years ago

Incorrect linkification of view-source if newline follows the linkinfied attribute.

Categories

(Core :: DOM: HTML Parser, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Assigned: cbartley)

References

Details

Attachments

(2 files)

See attachment.  View its source, and look at the links.  Copy the link locations and paste them into a text editor.

The view-source links seem to include everything to the end of line in the link, including the close-quote and the whitespace.  They should only include the attribute value.

Not sure whether we want to block on this, but it's making this feature pretty useless on a lot of pages for me...
Attached file The testcase
The attribute trimming code was checking for tab twice and newline never.  Now it will only check for tab once and will check for newline too.
Attachment #348018 - Flags: review?(mrbkap)
Attachment #348018 - Flags: superreview+
Attachment #348018 - Flags: review?(mrbkap)
Attachment #348018 - Flags: review+
Attachment #348018 - Flags: approval1.9.1b2?
Attachment #348018 - Flags: approval1.9.1b2? → approval1.9.1b2+
Comment on attachment 348018 [details] [diff] [review]
Trim function was not checking for newline in attribute values.

a=beltzner; sheriffs, this patch is safe to take along with any other checkin
Keywords: checkin-needed
Duplicate of this bug: 464390
Pushed changeset 6fee12207f39
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Duplicate of this bug: 464857
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.