flash objects: hover event no longer works

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: Salman Ansari, Unassigned)

Tracking

3.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

I only started experiencing this after upgrading to 3.0.4 build. Essentially, it seems that for all flash objects, the hover event is no longer being triggered. The easiest example of it is on youtube.com (any video really). Upon loading the page, hover over any of the buttons on the control bar. They won't respond. As a result, you cannot click pause because the player only allows you to do so when you hover it (which never gets triggered).

I'm able to reproduce this in other flash objects as well. In particular, the flash video player for my own company has a control bar that shows upon hover. This is no longer working (http://involver.com/).

Lastly, I should say the hover event is being triggered fine in other browsers (Safari, Opera).

Reproducible: Always

Steps to Reproduce:
1. Go to any YouTube video (e.g. http://www.youtube.com/watch?v=nXaS2EQrX7Q)
2. Hover over anything in the control bar (e.g. pause button, volume, full screen button)
Actual Results:  
None of the buttons respond at all to mouse hover.

Expected Results:  
The control bar buttons should be responding to hovers. e.g: 
- mouse changes to a hand and button changes to red color when hovering over the pause button
- volume control shows when hovering over volume button
- full screen button animates and becomes red on hover

I am using the default theme. I test flash players many times a day (in particular my own), and I can safely say I only started to notice this bug right after Firefox updated itself to 3.0.4
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5pre) Gecko/2008111306 GranParadiso/3.0.5pre

Everything works fine for me. Maybe caused by an add-on? Please try safe-mode to find out,
or if this doesn't help try a new profile:
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Or maybe Mac-only?
(Reporter)

Comment 3

10 years ago
I'm no longer able to repro this. It may have been a local issue, though a very strange one. Either way, marking as invalid.

Thanks for looking into this, though!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.