3pane context menu: Attachment icon context menu behavior

VERIFIED FIXED in Future

Status

P3
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: nbaca, Assigned: mscott)

Tracking

({polish})

Trunk
Future
All
Windows NT
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Build 2000-07-25-09M17: NT4
Haven't checked Mac or Linux yet.

Overview: In the Message Pane's Envelope area, right click onto the Attachment 
icon and nothing happens.

With a left click it shows:
- the name of the attachment (or attachments on seperate lines)
- Save All...

Expected Results:
a. I would expect a right click to show the context menu
b. Once the context menu appears then it should appear as follows:

- Save All
- Attachments... (I can't access the spec right now to describe the desired 
behavior but will this be possible?)
(Reporter)

Updated

18 years ago
Keywords: nsbeta3, polish
QA Contact: lchiang → nbaca

Comment 1

18 years ago
I have in the spec that we agreed that the context menu for the attachment 
button would contain only one item, "Save All Attachments...".  This still what 
we want? 
(Reporter)

Comment 2

18 years ago
I'm not sure why my copy of the spec is different than what is on gooey. "Save 
All Attachments" is fine with me.

Comment 3

18 years ago
reassigning to mscott.
Assignee: putterman → mscott
(Assignee)

Comment 4

18 years ago
I'm confused about what I need to do for this bug. Currently the context menu says:

Attachmen1 name
Attachment2 [details] [diff] name
---------
Save All

Is the bug that we just need to swith the order in which thee things are in the
menu?

Comment 5

18 years ago
Scott, what you currently have sounds great.

What nbaca was talking about was the difference between a right click and a left 
click. 

Right click:

<Attachment Name>
<Attachment Name>
---------------
Save All Attachments


Right click (context menu)
"Save All Attachments"

But it is fine with me if the Right and Left menus are identical. Especially if 
that is what you already have.  

PS, why is the name of this bug say "Attachment icon should match spec"? Is ther 
a different bug for the icon. I notice we are still using the old icon.
(Assignee)

Comment 6

18 years ago
cool thanks for the explanation Jennifer.

1) I have another bug for adding the new attachment icon you gave me (not sure
why this bug has the same summary)
2) So for this bug all I need to do is make sure the button acts like a context
menu (right mouse click) instead of responding to a left mouse click?

(Reporter)

Comment 7

18 years ago
Changing summary to reference the "context menu". I'm not sure why the original 
summary was titled '"Attachment icon should match spec'.
Summary: 3pane context menu: Attachment icon should match spec → 3pane context menu: Attachment icon context menu behavior

Comment 8

18 years ago
I had a typo above.  Sorry.  Scott, either of two options below is fine with me. 
Which ever is easier or already done.

1. Same menu, right and left click.
Attachmen1 name
Attachment2 [details] [diff] name
---------
Save All



Or
2. Only "Save All Attachments" in the Right click (context menu)
 and the menu above (#1) for a Left click (clicking on the button)

OK, does make sense now?  Sorry for the confusion. :-)

Comment 9

18 years ago
I say that we should just do the same for both right and left click.
Keywords: mail2

Comment 10

18 years ago
- per mail triage
Whiteboard: [nsbeta3-]
(Assignee)

Comment 11

18 years ago
future'ing minused bugs. 
Target Milestone: --- → Future

Comment 12

18 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Comment 13

18 years ago
*** Bug 65284 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
Adding my 2 cents.  I think that a context menu should be available for all
attachement.  The context should be Open and Save.  The Save All Attachment
should also be available as previously mentionned.  Once a week I receive some
documents by e-mail from my company.  My company sends all the docs in english
and french to a mailing list.  Let's say I receive 3 docs (6 files total), if I
can only save all attachement I'll have to delete 3 files everytime I get this
mail from my company. Pretty annoying.  Also, once saved, the context shouldn't
allow to save, only to open.  The context should be reset with a message change.

Comment 15

18 years ago
Ok, so it just me or is this bug fixed?
(Reporter)

Comment 16

18 years ago
Build 2001-01-2304: NT4
Build 2001-01-2204: Mac 9.04
Build 2001-01-1908: Linux 6.2

- Left-click context menus appear correctly:
Attachmen1 name
Attachment2 [details] [diff] name
---------
Save All

- Right-click context menus do not appear at all and should. 

Comment 17

18 years ago
An update since I'm trying to test Attachments.  The latest spec now says the 
context menu in the Attachment area should have Open, Save As..., Print..., 
[separator] Save All..., Properties.  This spec was last updated on 4-6-2001.  

Comment 18

17 years ago
Does this refer to the individual attachments shown when the message header bar
is expanded, or the small attachment icon shown when said bar is collapsed?

I have the normal contextual menu available under the former circumstance, but
no contextual menu under the latter. A click on the small attachment icon under
the latter circumstance results in the header bar expanding.
(Reporter)

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 19

17 years ago
I also see header bar (message envelop) expanding after right clicking on the
small attachment icon. Then right clicking on the attachment name brings context
menus: Open, Save As, Save All.
Current summary still reflects issues for attachment icon behavior - we just
have an additional issue. 

Comment 20

17 years ago
This bug was written based on the old attachment design, which was a single 
button. This feature has since been changed to the attachment listbox.

Recommend we close this bug and folks file new bugs on any issues they have with 
the new design as appropriate.

Spec for current design is here: 
http://www.mozilla.org/mailnews/specs/threepane/Attachments1.html
Includes notes for rfe features as well.
(Assignee)

Comment 21

17 years ago
ok...closing.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
Verified with new design - now clicking on Attachment icon opens the Attachment
area. Right mouse click retrieves context menu.
Status: RESOLVED → VERIFIED
Keywords: nsbeta3
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.