moving a folder results in a copy (duplicated) when drag and drop

RESOLVED DUPLICATE of bug 199079

Status

--
major
RESOLVED DUPLICATE of bug 199079
10 years ago
10 years ago

People

(Reporter: ms1003, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.17 (20080914)

Folder Structure:
Local Folders
- Business (folder)
- - Name 1 (folder with several emails)
- - Name 2 (folder with several emails)

- Archive (folder)
- - Category 1 (folder)

When I drag the folder 'Name 1' in the left pane and drop it onto the folder 'Category 1' all appears to work - Name 1 is removed from 'Business' and appears in 'Category 1' but looking into the profile I still find the mbox file 'Name 1' in the folder Business.sdb and it is open so that it can not be removed in Explorer. The file 'Name 1.msf' has been removed.

After TB is closed and restarted the folder Business contains again the folder 'Name 1'.

Reproducible: Always

Steps to Reproduce:
1. described above
2.
3.
Actual Results:  
duplicate mail folders with all the contained mail messages

Expected Results:  
that the folder is actually moved and not copied
This is a duplicate of bug 274827...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 274827
(Reporter)

Comment 2

10 years ago
This might well be the same bug, but different than the other bugs of which this might be a duplicate, this done does not involve imported outlook express folders. As described it should be easy to duplicate the bug - easier than to import a big number of OE folders.
I tried to make the description to duplicate the problem as concise as possible - if somebody will work on this I can stand by and assist.

Merlin

Comment 3

10 years ago
duping all the way to 199079 instead of bug 274827
Duplicate of bug: 199079

Comment 4

10 years ago
a thought - I'm not sure the causes of the older bug(s) would be the same as Merlin's issue.  Hard to say, given almost everyone in the older bugs seems to be gone.

Merlin, can you reproduce using trunk build?
 backup your profile before using
 ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/
You need to log in before you can comment on or make changes to this bug.