Request icon/noicon properties in Places tree

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
9 years ago
2 months ago

People

(Reporter: Ed Hume, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081113 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081113 Minefield/3.1b2pre

In aboutSessionRestore.css we now have a distinction between icon and noicon in the tree selectors (see e.g. lines 11-12).

In my Aeon Big theme I use 24-pixel icons for theme-provided menu icons - except in the Places Library and sidebar. Everywhere else I can make a distinction between favicons (usually 16px) and theme-provided menuicons. 

In the Places Library and sidebar there is no icon property and no noicon property, so I must use 16-pixel icons, which my users find hard to see. If the icon/noicon properties present in the session restore dialog were available in the Places tree, I could provide 24-pixel menuicons where websites do not have favicons.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



I consider this an accessibility issue.

Updated

9 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Since we no longer support full themes, and the default image handling works fine for us, I think this is now a wontfix.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.