Shift-Tab does not move the focus backwards

RESOLVED FIXED in mozilla1.9.2a1

Status

Core Graveyard
Widget: Qt
--
minor
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: Steffen Imhof, Assigned: Steffen Imhof)

Tracking

unspecified
mozilla1.9.2a1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko
Build Identifier: MOZILLA_VERSION 1.9.1b2pre

Pressing Tab moves the focus forward as expected, but Shift-Tab does not move it at all.

Reproducible: Always

Steps to Reproduce:
1. Go to a website with multiple focusable elements (links, input fields, ..)
2. Try to move the focus with Shift-Tab
Actual Results:  
Nothing happens

Expected Results:  
Focus should move backwards in the tab-order.
(Assignee)

Comment 1

10 years ago
Created attachment 348163 [details] [diff] [review]
Patch to map Qt::Key_Backtab to NS_VK_TAB

The cause of the problem is, that Qt has a special virtual key code for "Backtab" which is not mapped to a NS_VK_* code. The patch adds a line to nsQtKeyUtils.cpp that maps it to NS_VK_TAB. It seems this should be ok, because the shift-state is handled extra anyway.
Comment on attachment 348163 [details] [diff] [review]
Patch to map Qt::Key_Backtab to NS_VK_TAB

Works fine for me
Attachment #348163 - Flags: review+
Comment on attachment 348163 [details] [diff] [review]
Patch to map Qt::Key_Backtab to NS_VK_TAB

I'm not sure is it ok to have my review for such patches? or I always need get review from someone else?
Attachment #348163 - Flags: review?(vladimir)

Comment 4

10 years ago
Is there anything that could be done to get this patch accepted?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Attachment #348163 - Flags: review?(vladimir) → review+

Updated

9 years ago
Whiteboard: checkin-needed
Assignee: nobody → steffen.imhof
http://hg.mozilla.org/mozilla-central/rev/821dba792e8c
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: checkin-needed
Target Milestone: --- → mozilla1.9.2a1
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.