Search detection should be automated

RESOLVED DUPLICATE of bug 411226

Status

SeaMonkey
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 411226
10 years ago
10 years ago

People

(Reporter: Kuo Chiang, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13

Search detection should be automated in a sense where users do not need to explicitly click on the search button to conduct a search. Anything without a scheme or domain name should be automatically converted to a search term when the user press on ‘Enter’. In addition, keywords entered on the address bar should also search for URLs within the users’ history based on description. 



Reproducible: Always

Comment 1

10 years ago
On SeaMonkey 2.0a1 is item 'Perform a web search when entered text is not a web location' in 'Edit-Preferences-Browser-Location Bar'.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: General → Preferences
QA Contact: general → prefs
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 411226

Comment 2

10 years ago
You can also enable internet keywords in the 1.1.13 "Smart Browsing" preferences (and combine that with Domain Guessing).
You need to log in before you can comment on or make changes to this bug.