Closed Bug 464914 Opened 11 years ago Closed 2 years ago

AltGr (or Ctrl+Alt or plain Alt) triggers email address selection from the contacts autocomplete suggestion list

Categories

(Thunderbird :: Message Compose Window, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: rimas, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

If when writing a recipient address, I press AltGr key (or Ctrl+Alt) and there are suggestions based on what I have input, the first one is being selected automatically.

This is very annoying for users of keyboards that employ AltGr to enter characters, especially the default Lithuanian layout, where AltGr and Shift are required to enter the @ character.
Magnus, I'm CC'ing you here as you seem to be the most active Thunderbird developer that I see on Bugzilla. Could you take a look at this? This bug is very annoying, and shouldn't slip to the release IMHO.
Severity: normal → major
Flags: blocking-thunderbird3?
What I see on linux is that Alt selects the suggestion. (AltGr doesn't, and Ctrl doesn't seem to matter.) TB2 doesn't have this behavior.

Mark: is this something that changed with the toolkit autocomplete changes?
Keywords: regression
We haven't actually changed the UI interface to toolkit autocomplete yet.

I would investigate what FF does in a similar situation.

It may be possible that we did change something whilst implementing some changes in xpfe to support the toolkit interfaces, Neil will probably have an idea if we did.
(In reply to comment #2)
> What I see on linux is that Alt selects the suggestion. (AltGr doesn't, and
> Ctrl doesn't seem to matter.) TB2 doesn't have this behavior.

Yes. On Windows, plain Alt focuses the menu bar, but I thought that was acceptable, so didn't mention that. My bad. Meanwhile the AltGr key doesn't focus anything, just triggers autocomplete.

BTW, AltGr equals Ctrl+Alt on Windows, and AFAIK when you press AltGr, two events are fired: Ctrl keypress and Alt keypress. This may explain why this bug is reproducable with AltGr on Windows and not Linux.

However, feel free to change the summary to "Alt triggers email selection from the suggestion list" if this is also undesirable, and change the Platform/OS fields accordingly.
I don't think firefox ever has the same behavior (in the url bar, the suggestions are in a list below - not next to what you're typing). SeaMonkey has the same bug as thunderbird.
The problem is trying to figure out when we do want to close the popup.
1. Alt+Ctrl+E: Alt down; Ctrl down; é down; é up; Ctrl up (no alt up!)
2. Ctrl+Alt+E: Ctrl down; Alt down; é down; é up; Alt up; Ctrl up
3. Alt+E: Alt down; E down; (should close popup)
4. Alt: Alt down; Alt up; (should close popup)
Fortunately AltGr sends Ctrl down before Alt down so we could ignore case 1...

I don't think Firefox does anything if you press Alt.
Blocks: 270128
(In reply to comment #5)
Here's a difference between Fx and Tb:

in Firefox, I can open and navigate the menu, and all suggestions are still visible. They are only hidden when I open a new window (e.g. preferences)

in Thunderbird, as I said before, even focusing the menu by just pressing Alt hides all suggestions and uses the one that was already in the input field as a choice.

I'm not sure if consistency is required here, but if it was, I'd like to see in both apps the Firefox behaviour. 

(In reply to comment #6)
No, I don't think you could ignore case 1, this would be inconsistent.
Attached patch Proposed patchSplinter Review
This uses the accessibility event that's generated when the menu bar is activated to determine when to close the results popup.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #352084 - Flags: review?(bugzilla)
Duplicate of this bug: 470610
This bug should be renamed to improve retrievability:

AltGr (or Ctrl+Alt) triggers email address selection from the contacts autocomplete suggestion list

This bug should definitely be a blocker, because in countries like Lithuania or Germany where holding AltGr is necessary to type the @ sign, this bug makes it practically impossible to enter any email address which resembles a known contact.
Bug 470656 addresses a similar problem: pressing normal editing keys triggers unwanted contact selection from autocomplete suggestion list (Bug 470656 - Autocomplete reinstates undesired to-recipient contacts, e.g. after cursor left or DEL (can't delete suggested email address))
blocking‑thunderbird3+
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Summary: AltGr (or Ctrl+Alt) triggers email selection from the suggestion list → AltGr (or Ctrl+Alt) triggers email address selection from the contacts autocomplete suggestion list
Target Milestone: --- → Thunderbird 3.0b2
Comment on attachment 352084 [details] [diff] [review]
Proposed patch

Looks good, lets give this a try in the real world.
Attachment #352084 - Flags: review?(bugzilla) → review+
Summary: AltGr (or Ctrl+Alt) triggers email address selection from the contacts autocomplete suggestion list → AltGr (or Ctrl+Alt or plain Alt) triggers email address selection from the contacts autocomplete suggestion list
Pushed changeset abb24c645b1d to mozilla-central.

Pushed changeset eb5f0413e6c3 to releases/mozilla-1.9.1
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Verifying with a windows build.
Status: RESOLVED → VERIFIED
Depends on: 476422
I face the exact same issue with Thunderbird 17.0.2, on Ubuntu 12.04.2 (with 2 different computers : one with the x86 version and the other wih x64)
Should I open another bug?
Mossroy, if this is an Ubuntu package you are using, then you should probably file a bug in Launchpad and let the maintainers of Ubuntu package to investigate the case first. If this is an official Mozilla's build however, you should probably file a new bug, as this one is really old and has been fixed long ago. However, in that case, I'd suggest to see if using the latest available version of Thunderbird would fix the problem. FWIW, I'm not seeing this issue with Thunderbird 21 daily build on Debian.
You're right, I'm using the ubuntu package, and will follow your suggestions.
Thanks for your feedback on Thunderbird on Debian, and sorry for the inconvenience.
I'm experiencing the same problem on my System:
Ubuntu 14.04.02 LTS
Thunderbird: 31.6.0
Language: German (@ = AltGr + q)
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/baadbaceab38
(regression from bug 270128) Watch for menubar activation r=Standard8
Status: VERIFIED → RESOLVED
Closed: 11 years ago2 years ago
You need to log in before you can comment on or make changes to this bug.