uw imapd container quirk

VERIFIED DUPLICATE of bug 46494

Status

MailNews Core
Networking: IMAP
P3
enhancement
VERIFIED DUPLICATE of bug 46494
18 years ago
9 years ago

People

(Reporter: timeless, Assigned: jefft)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The University of Washington IMAPD doesn't allow clients to use folders for 
both mail and folders.

When checking folders and mail if mozmail realizes that the server behaves like 
a uw-imapd it should do the following behavior:
Pair folders (eg Inbox) and Directories (eg Inbox.sbd/). -- This behavior 
mimics mozmail behavior for local mail folders. [a Folder contains messages; a 
Directory contains containers, both Folders and Directories are containers.]

If a user tries to move a container (eg "Drafts") into a mail folder (egInbox):
* the paired directory (eg Inbox.sbd/) is created if it doesn't exist.
* the container (Drafts and Drafts.sbd/) is moved into the paired directory (eg 
Inbox.sbd/).

If a user tries to move a message into a folder (eg from Inbox to 
Personal.sbd/):
* the paired folder (eg Personal) is created if it doesn't exist.
* the message is moved into the paired folder (eg Personal).

When a user creates a folder we can just create the mail folder, or we can 
create the pair.
--
* I think I read that an imap agent can not assume that because we spoke w/ a 
uw-imapd server at 10.0.4.1 last time that the next time we talk to that ip ... 
will have a uw-imapd server.  This can be addressed later.

* The directory separator is server specified, for demonstration I used '/', in 
practice this would be auto detected.
(Reporter)

Comment 1

18 years ago
Sorry for the spam, bugzilla burped.

*** This bug has been marked as a duplicate of 46494 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.