8bit mime causing email to bounce

RESOLVED INVALID

Status

defect
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: andrew.norfolk02, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-GB; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2pre) Gecko/20081113 Shredder/3.0b1pre

Some of my emails bounce when the content is sent with purely 8bit mime text.
I think this could be because my smtp server is Exchange and therefore rubbish (and won't attempt to transcode to 7bit when relaying to a server that doesn't support 8bit).
It also seems to have only started in the last few days.
Is there a way of turning off 8bit?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
The checkbox for quoted-printable encoding was removed per bug 448702 as it was considered no longer relevant for the majority of SMTP servers. Apparently you encountered one of the few servers which can't correctly handle 8-bit MIME encoding, which is strictly speaking a bug in that server.

Since only the UI was removed but not the preference itself, you can set mail.strictly_mime using the Config Editor in Thunderbird > Preferences > Advanced > General. Note that this will affect all outgoing messages.

This bug should be resolved as INVALID if this was the only reason for filing it. If you notice some other apparent corruption of your 8-bit messages beyond that, we would need to investigate further if a regression has been introduced somewhere. Please examine the copy in your Sent folder and report back if you see any issues in its 8-bit encoding.

Comment 2

11 years ago
No feedback from reporter, thus resolving per comment #1 as server issue.
Feel free to reopen if you have further information to add.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.