Login autocomplete results no longer sorted

RESOLVED DUPLICATE of bug 107957

Status

()

RESOLVED DUPLICATE of bug 107957
10 years ago
4 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
mozilla1.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

Autocomplete results of usernames in a login form are not sorted alphabetically like they were in Firefox 2. There is a possibly related bug 418343 which fixed the sorting in any other form field than username fields.

Reproducible: Always

Steps to Reproduce:
1. Find a login form
2. Enter "a" as username and a password and click the login button
3. Choose to remember the password
4. Go back to the login form and repeat step 2 and 3 this time using "c" as username
5. Do step 4 again, but using "b" as username this time
6. Go back to the login form and double click the username field to bring up the autocomplete results.
Actual Results:  
The autocomplete results are not sorted. The order is "a", "c", "b"

Expected Results:  
The autocomplete results are sorted alphabetically. The order is "a", "b", "c"

This bug is copied to bugzilla from http://forum.mozilladanmark.dk/viewtopic.php?t=4727 . The original reporter was Thomas Allan.
(Reporter)

Comment 1

10 years ago
Created attachment 348217 [details]
A login form you can test with
Assignee: nobody → dolske
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla1.9.1
Version: unspecified → Trunk
Created attachment 348220 [details] [diff] [review]
Patch v.1

Bah, the sort logic has been wrong all along. It's probably only partially sorting results, just enough to pass the current tests. Need to look if there's a way to jigger the tests to reliably fail with the current code.

Comment 3

10 years ago
How do I apply the patch?

Comment 4

8 years ago
Is this a dupe of bug 107957?
Assignee: dolske → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 107957
You need to log in before you can comment on or make changes to this bug.