Mozilla spins on invalid markup with unbalance quotes

VERIFIED WORKSFORME

Status

()

Core
HTML: Parser
P5
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Carrer Yuri, Assigned: harishd)

Tracking

({crash, testcase})

Trunk
Future
crash, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If you go to http://www.alfa.it/, at the bottom of the page, and do a search
(the button is called "Cerca"), it freezes :) you have to kill the process (ctrl
alt del and kill task under Windows)

Comment 1

18 years ago
Works for me, build 2000-07-24-08 on Windows 98SE.
Carrer, can you provide more details please, what build are you using?
what text did you write in the search box? Is it repeatable? Thanks.

Comment 2

18 years ago
Works for me with build ID 2000072520 on NT
I searched sexe and was presented with a page
saying no match found.

Comment 3

18 years ago
Works for me using Build ID: 2000072520 on Windows 98.

Comment 4

18 years ago
WFM on Linux 2000072508.  I searched for "ciao".

Comment 5

18 years ago
Oops.  Actually I'll confirm this on Linux.  Looks like I didn't observe the
page long enough.  The page painted, but then the browser hung after that.  I
searched for "ciao" again and the browser hung before painting.  It is spinning
on the CPU without making any system calls.

Interestingly, at the point it hangs, the barber pole reads "539%", or "313%" or
some other percentage greater than 100.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
OS: Windows 95 → All
Hardware: PC → All

Comment 6

18 years ago
I testcased this one on Linux build 2000072508.  The search results page at
http://www2.alfa.it/cgi-bin/htsearch?words=ciao contains invalid markup.  Here
is a five-liner that makes mozilla spin:

<html>
    <body>
        <p ">
    </body>
</html>

Note the unbalanced quote.  If you balance or remove the quote, the page renders
without the crash.  Obviously the markup is to blame but Mozilla should handle
it gracefully.  Reassigning to parser.
Assignee: asa → rickg
Component: Browser-General → Parser
Keywords: testcase
QA Contact: doronr → janc
Summary: the browser freeze (blocks) when a form is clicked → Mozilla spins on invalid markup with unbalance quotes

Comment 7

18 years ago
Created attachment 11943 [details]
Trivial testcase
(Assignee)

Comment 8

18 years ago
assigning to myself to analyse the problem. Setting the lowest priority.
Assignee: rickg → harishd
Priority: P3 → P5
(Assignee)

Comment 9

18 years ago
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this
is an error, that you or another known resource will be working on this bug,or 
if it blocks your work in some way -- please
attach your concern to the bug for reconsideration. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 10

18 years ago
*** Bug 51303 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
This was fixed a while back. Marking WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 13

17 years ago
Verified on
build: 2001-05-07-06-Trunk
Platform: Win NT
Status: RESOLVED → VERIFIED

Comment 14

10 years ago
Crashtest added as part of http://hg.mozilla.org/mozilla-central/rev/5a6def05ccbc
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.