Closed Bug 464978 Opened 11 years ago Closed 11 years ago

TM: hang with "[] + null"

Categories

(Core :: JavaScript Engine, defect, P1, critical)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9.1b2

People

(Reporter: jruderman, Assigned: brendan)

References

(Blocks 1 open bug)

Details

(4 keywords)

Attachments

(2 files, 2 obsolete files)

Attached file sample
This hangs ./js -j:

for (let j = 0; j < 2; ++j) { [] + null; }
Looping in an imacro, pc is not being advanced. 

bug 464911 and bug 464686 might be from this
Assignee: general → brendan
This should block b2. Fallout from imacros, late in the evolution of that patch.

/be
Blocks: imacros
Status: NEW → ASSIGNED
Flags: blocking1.9.1?
OS: Mac OS X → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.9.1b2
Flags: blocking1.9.1? → blocking1.9.1+
Attached patch proposed fix (obsolete) — Splinter Review
Need one more bit of state to communicate back, from the record_* method that calls an imacro to the RECORD_ARGS macro that redirects regs.pc, to the imacro's entry point, the fact that the imacro is starting.

Then when the same opcode (one compile-time-specialized via the JSOP_IS_BINARY(x) and other x == JSOP_* tests), JSOP_ADD in the testcase here, is included in the body of the imacro, we won't redirect again to the entry point and iloop.

/be
Attachment #348291 - Flags: review?(danderson)
Attachment #348291 - Flags: review?(danderson) → review+
Attached patch patch to commit (obsolete) — Splinter Review
Simplified imacro-start condition, added comment.

/be
Attachment #348291 - Attachment is obsolete: true
Attachment #348295 - Flags: review+
Comment on attachment 348295 [details] [diff] [review]
patch to commit

This has to go into b2. Too much ilooping (hard, no watchdog) sad Firefox without.

/be
Attachment #348295 - Flags: approval1.9.1b2?
Blocks: 465063
Duplicate of this bug: 465063
Fixed in tm:

http://hg.mozilla.org/tracemonkey/rev/473d1ce28a3b

/be
No longer blocks: 465063
A few tweaks to comments and avoiding else after return.

/be
Attachment #348295 - Attachment is obsolete: true
Attachment #348356 - Flags: review+
Attachment #348295 - Flags: approval1.9.1b2?
Comment on attachment 348356 [details] [diff] [review]
patch I committed for the record

I diff'ed tm and m-c, and it would be best to sync 'em soon. Just asking for individual patch approval, still favor sync'ing to avoid doing things by hand and risking PEBKAC problems.

/be
Attachment #348356 - Flags: approval1.9.1b2?
Attachment #348356 - Flags: approval1.9.1b2? → approval1.9.1b2+
Comment on attachment 348356 [details] [diff] [review]
patch I committed for the record

yeah, I'll try to sync at an opportune time.
Thanks to sayrer for syncing to m-c.

http://hg.mozilla.org/tracemonkey/rev/473d1ce28a3b
http://hg.mozilla.org/mozilla-central/rev/473d1ce28a3b

/be
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
test landed http://hg.mozilla.org/mozilla-central/rev/4a446182cc44 and cvs
Flags: in-testsuite+
Flags: in-litmus-
v 1.9.1, 1.9.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.