Custom view name (Bug 439489) now crashes trunk [@ nsMsgThreadedDBView::MoveThreadAt] ... [@ nsStringBuffer::Release]

RESOLVED DUPLICATE of bug 464802

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED DUPLICATE of bug 464802
9 years ago
7 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

(Depends on: 1 bug, {crash, regression})

Trunk
x86
Windows Vista
crash, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081114 Shredder/3.0b1pre

create custom view, change to folder A, change custom view, crash. 
restart, crash. 
go back to older build, no crash but view=undefined
reproducible: ~100%, either immediately, or after a brief delay (a new message entering folder?)

regression range
no crash 20081110
crash 20081113

bp-3c01af3c-45d8-451e-bdf7-13ec20081114

ntdll.dll	ntdll.dll@0x659c3	
ntdll.dll	ntdll.dll@0x65882	
kernel32.dll	kernel32.dll@0x4c56e	
msvcr80.dll	msvcr80.dll@0x4c38	
xpcom_core.dll	nsStringBuffer::Release	xpcom/string/src/nsSubstring.cpp:191
xpcom_core.dll	nsAString_internal::Finalize	xpcom/string/src/nsTSubstring.cpp:205
thunderbird.exe	thunderbird.exe@0x58befe
(Reporter)

Comment 1

9 years ago
tested hourly build, crasher fixed by bug 464802

back to behavior of rkent's Bug 439489
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Summary: Custom view name (Bug 439489) now crashes trunk [@ something] [@ nsStringBuffer::Release] → Custom view name (Bug 439489) now crashes trunk [@ nsMsgThreadedDBView::MoveThreadAt] ... [@ nsStringBuffer::Release]
Duplicate of bug: 464802
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMsgThreadedDBView::MoveThreadAt] [@ nsStringBuffer::Release]
You need to log in before you can comment on or make changes to this bug.