Closed Bug 465003 Opened 11 years ago Closed 11 years ago

Don't initialize global vars early in nsUpdateService.js.in UpdateService function

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 471219

People

(Reporter: robert.strong.bugs, Unassigned)

Details

Pretty much everything initialized in UpdateService doesn't need to be. A quick cleanup of this resulted in a TS improvement using Talos standalone on Windows.
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/src/nsUpdateService.js.in#1021

TS Average Before: 517.58
TS Average After : 496.38
TS Gain: 21.2
TS Percentage Gain 4%
Looks to be more like around a 3% gain
This will be fixed by bug 471219 so duping
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471219
You need to log in before you can comment on or make changes to this bug.