seamonkey not working with 1.6.0 java-openjdk-plugin gcjwebplugin.so

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: Philip Walden, Unassigned)

Tracking

SeaMonkey 1.1 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080925 Fedora/1.1.12-1.fc9 SeaMonkey/1.1.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080925 Fedora/1.1.12-1.fc9 SeaMonkey/1.1.12

This is on a freshly installed Fedora 9 instance using the new java-openjdk-plugin 1.6.0 package in Fedora 9. However, my standard test applet page (http://www.can-d.net/plus.htm) does not work, it says the java may not be enabled.

Seamonkey does show the gcjwebplugin.so plugin as registered in the
about:plugins page and yes, Java is enabled in the advanced preferences. The about:plugins shows:

GCJ Web Browser Plugin (using IcedTea) 1.2

    File name: gcjwebplugin.so
    The GCJ Web Browser Plugin (using IcedTea) executes Java applets.

MIME Type     Description     Suffixes     Enabled
application/x-java-vm         IcedTea     class,jar     Yes
application/x-java-applet     IcedTea     class,jar     Yes
application/x-java-applet;version=1.1     IcedTea     class,jar     Yes
...etc

If I fire up firefox, the plugin also shows as registered and the above applet works! I can also fire up the openjdk Java Monitoring & Management Console and everything looks good.

Running seamonkey from a terminal command line yields no errors to the terminal screen. The Tools > Web Development menu does show the Java console as grayed out. The Error console has no errors related to java.

I have run this by the mozilla newsgroups too, with no good response.




Reproducible: Always

Steps to Reproduce:
1. Install the plugin su -c 'yum install java-1.6.0-openjdk{,-plugin}'
2. Restart seamonkey
3. Try http://www.can-d.net/plus.htm
Actual Results:  
Page prints

Can't start Java Applet - Java may be disabled

Expected Results:  
a working VCR+ code calculator applet

Firefox works while seamonkey does not.

Work around is to use the Sun java plugin.

Comment 1

10 years ago
What version of Firefox did you use?
(Reporter)

Comment 2

10 years ago
This is copied from my firefox about page

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008092318 Fedora/3.0.2-1.fc9 Firefox/3.0.2
Can you reproduce with SeaMonkey v2.0a1 ?
Version: unspecified → SeaMonkey 1.1 Branch

Comment 4

9 years ago
I have this problem with seamonkey 2.0a3.  I compiled Seamonkey myself, since I wanted a 64-bit Linux version, and Seamonkey itself works great.  I have the java plugin installed on my Fedora 10 system.  However, Seamonkey just does not see it.

Comment 5

9 years ago
Follow-up: after doing:

sudo ln -s /usr/lib64/gcj-4.3.2/libgcjwebplugin.so /usr/local/lib/seamonkey-2.0a3/plugins

about:plugins shows Java support, but when I try to start a Java application (e.g. http://www.java.com/en/download/installed.jsp?detect=jre), Seamonkey crashes.  The command line output is:

GCJ PLUGIN: thread 0x7f346ee06600: NP_Initialize
GCJ PLUGIN: thread 0x7f346ee06600: NP_Initialize: using /usr/bin/gappletviewer.
GCJ PLUGIN: thread 0x7f346ee06600: NP_Initialize return
GCJ PLUGIN: thread 0x7f346ee06600: GCJ_New
GCJ PLUGIN: thread 0x7f346ee06600: plugin_data_new
GCJ PLUGIN: thread 0x7f346ee06600: plugin_data_new return
GCJ PLUGIN: thread 0x7f346ee06600: plugin_get_documentbase
GCJ PLUGIN: thread 0x7f346ee06600: plugin_get_documentbase return
../../../../../../libjava/classpath/native/plugin/gcjwebplugin.cc:978: thread 0x7f346ee06600: Error: Failed to read line from whitelist file.
GCJ PLUGIN: thread 0x7f346ee06600: NP_GetValue
GCJ PLUGIN: thread 0x7f346ee06600: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x7f346ee06600: NP_GetValue return
GCJ PLUGIN: thread 0x7f346ee06600: GCJ_GetValue
GCJ PLUGIN: thread 0x7f346ee06600: GCJ_GetValue: returning TRUE for NeedsXEmbed.
GCJ PLUGIN: thread 0x7f346ee06600: GCJ_GetValue return

(seamonkey-bin:9778): Gdk-CRITICAL **: gdk_window_get_user_data: assertion `window != NULL' failed

(seamonkey-bin:9778): Gtk-CRITICAL **: gtk_container_add: assertion `GTK_IS_CONTAINER (container)' failed

(seamonkey-bin:9778): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)' failed

(seamonkey-bin:9778): Gtk-CRITICAL **: gtk_socket_get_id: assertion `GTK_WIDGET_ANCHORED (socket)' failed
/usr/local/lib/seamonkey-2.0a3/run-mozilla.sh: line 131:  9778 Segmentation fault      "$prog" ${1+"$@"}


It would be nice if plugin failures didn't cause Seamonkey to crash like this.
(Reporter)

Comment 6

9 years ago
This is still a problem for me even with the recent FC9 updates:

java-1.6.0-openjdk-1.6.0.0-0.23.b09.fc9.i386
java-1.6.0-openjdk-plugin-1.6.0.0-0.23.b09.fc9.i386
seamonkey-1.1.14-1.fc9.i386
firefox-3.0.8-1.fc9.i386


Firefox works, but Seamonkey does not.

Comment 7

9 years ago
running plugins in their own processes is covered by another bug.

you're comparing very unrelated products and expecting it to be a useful comparison.

It's like saying "why did your grandfather slip on that bridge?, my father can walk across it without tripping"

in gecko apps, what matters is the gecko version

seamonkey1.1 = rv:1.8.1
firefox3.0 = rv:1.9

Please rebuild gcj w/ --enable-debug --disable-strip --without-sucky-optimizations and use
./firefox -d gdb -g
and get a backtrace when it crashes

If it's GCJ's fault, please file the bug against them and report the bug url here.
(Reporter)

Comment 8

9 years ago
I was not meaning to compare seamonkey to firefox. I was intending to point out that my java-openjdk installation is correct and works in firefox and that it does not work in seamonkey. Hence the greater probability that it might be a seamonkey issue.

Comment 9

9 years ago
(In reply to comment #8)
> I was not meaning to compare seamonkey to firefox. I was intending to point out
> that my java-openjdk installation is correct and works in firefox and that it
> does not work in seamonkey. Hence the greater probability that it might be a
> seamonkey issue.

timeless wanted to point out that you can't compare seamonkey 1.1.14 (grandfather) and firefox 3.0.8 (father). They're from 2 different gecko branches (1.8.1 and 1.9). That is, seamonkey 1.1.14 is from a much older branch than firefox 3.0.8
Philip, Timur, can either of you still reproduce this with SeaMonkey 2.0 or later?
(Reporter)

Comment 11

8 years ago
I'm on SM 2.0.3 now. The problem appears to be gone.

However, my FF now has a problem with openjdk :)
Resolving WFM in line with comment 11. Timur, if you still see this with SM 2.0 or later, please reopen. Philip, for the FF issue, please open a new bug if need be. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Depends on: 780729

Updated

6 years ago
Depends on: 780730

Updated

6 years ago
Depends on: 780731

Updated

6 years ago
No longer depends on: 780731

Updated

6 years ago
No longer depends on: 780729

Updated

6 years ago
No longer depends on: 780730
You need to log in before you can comment on or make changes to this bug.