JavaScript error on webpage

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
minor
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Gordon Ross, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The buttons down the left-hand side of the page don't work under Mozilla. When
moving the mouse over them, you get erratic behaviour, and the screen starts to
get corrupted

Comment 1

18 years ago
Although there is no screen corruption or erratic behavior, the buttons stay 
highlighted yellow and certain images do not appear on the screen as they 
should. Please assign where necessary.
072608 NT4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Buttons don't work on home page → JavaScript error on webpage

Comment 2

18 years ago
Thank you for reporting this bug, but I have to mark it as invalid.
The web page has HTML that detects layers incorrectly. At the bottom 
of the HTML file, there is the following script block:

<SCRIPT LANGUAGE="JavaScript1.3">
<!--
        gotlayers = 1;
// -->
</SCRIPT>


The mousover events of the buttons on the page all call this: 

function popUp(menuName,on) {
    if (gotlayers) {
            if (on) {
                moveLayers();
                if (NS4) {
                       document.layers[menuName].visibility = "show";
                } else {
                       document.all[menuName].style.visibility = "visible";
                }
            } else {
                if (NS4) {
                       document.layers[menuName].visibility = "hide";
                } else {
                       document.all[menuName].style.visibility = "hidden";
                }
            }
    }
}

Because "gotlayers" has been set to 1, Mozilla falls into code where 
document.all  is used. Since Mozilla does not support document.all, 
the page will not function. On my WinNT box, I get the following error 
in the JavaScript console: 

                 document.all has no properties


The author of the web page tests elsewhere for the browser version, 
but as long as the block above sets "gotlayers" to 1, the page is not 
going to function properly in Mozilla.

See bug 46382 for further links on features supported in NN4.x that are 
not supported in Mozilla...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Javascript Engine → DOM Level 0
Resolution: --- → INVALID

Comment 3

17 years ago
Marking Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.