Assertion failure: title->u.count == 0, at js/src/jslock.cpp:1357

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
blocker
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: mats, Assigned: Igor Bukanov)

Tracking

({assertion})

Trunk
x86
Linux
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 348397 [details]
stack

STEPS TO REPRODUCE
1. open all Alexa Global Top 100 sites in tabs
2. on a tab context menu: click "Reload All Tabs" a few times

ACTUAL RESULT
Assertion failure: title->u.count == 0, at js/src/jslock.cpp:1357

PLATFORMS AND BUILDS TESTED
Local Firefox debug build, x86-64 Linux.

Comment 1

9 years ago
I get this now when running mochitest (/dom/src/threads/test) on x64_64 Linux.
This is a blocker for me, since I can't run mochitest atm.

Main thread looks like this
#0  0x00000032d900a486 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00002aaaab9340af in PR_WaitCondVar (cvar=0x74bd80, timeout=4294967295)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/nsprpub/pr/src/pthreads/ptsynch.c:417
#2  0x00002aaaaad5f787 in js_GC (cx=0x1051830, gckind=GC_NORMAL)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/js/src/jsgc.cpp:3381
#3  0x00002aaab0214469 in nsXPConnect::Collect (this=0x6cefd0)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/js/src/xpconnect/src/nsXPConnect.cpp:477
#4  0x00002aaaab2a8e25 in nsCycleCollector::Collect (this=0x2aaab01d0010, aTryCollections=1)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/xpcom/base/nsCycleCollector.cpp:2277
#5  0x00002aaab0b40149 in nsJSContext::CC () at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/dom/base/nsJSEnvironment.cpp:3430
#6  0x00002aaab0b4221d in GCTimerFired (aTimer=<value optimized out>, aClosure=<value optimized out>)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/dom/base/nsJSEnvironment.cpp:3538
#7  0x00002aaaab29cf9b in nsTimerImpl::Fire (this=0x5ae4db0)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/xpcom/threads/nsTimerImpl.cpp:427
#8  0x00002aaaab29daea in nsTimerEvent::Run (this=0x2aaabc512750)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/xpcom/threads/nsTimerImpl.cpp:519
#9  0x00002aaaab2994bd in nsThread::ProcessNextEvent (this=0x66c780, mayWait=1, result=0x7fffaf0869fc)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/xpcom/threads/nsThread.cpp:510
#10 0x00002aaaab2551e3 in NS_ProcessNextEvent_P (thread=0x74bd8c, mayWait=1) at nsThreadUtils.cpp:230
#11 0x00002aaab9807dda in nsBaseAppShell::Run (this=0xdf4980)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:170
#12 0x00002aaab70a481b in nsAppStartup::Run (this=0xeca2a0)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/toolkit/components/startup/src/nsAppStartup.cpp:193
#13 0x00002aaaaaaea77f in XRE_main (argc=<value optimized out>, argv=<value optimized out>, aAppData=<value optimized out>)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/toolkit/xre/nsAppRunner.cpp:3359
#14 0x0000000000400eca in main (argc=5, argv=0x0)
    at /home/smaug/mozilla/mozilla_cvs/hg/mozilla/browser/app/nsBrowserApp.cpp:156
Severity: normal → blocker
(Assignee)

Updated

9 years ago
Assignee: general → igor
(Assignee)

Comment 2

9 years ago
(In reply to comment #1)
> I get this now when running mochitest (/dom/src/threads/test) on x64_64 Linux.

This is due to the bug 492659. Note that this is unrelated to the report from the comment 0 as the bug 492659 is a regression from the bug 489501 which landed on 2009-05-01.
Depends on: 492659
(Assignee)

Comment 3

7 years ago
The corresponding code was removed in the bug 606029.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.