Visited links don't change color

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: joshshb, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

When I go to visit a website such as Google, Reddit, Wikipedia, or any other site that changes link color after visiting it, the color doesn't change. In the case that it does change, refreshing the page just reverts it back to the unvisited color. I have to tell you though, never before have I been so annoyed by a sea of blue links.

In any case, the links I did visit before this problem presented itself about a week ago still remain purple - my choice color for visited links. It is only the new links that I have visited within the past week that remain blue for seemingly no reason.

Reproducible: Always

Steps to Reproduce:
1. Visit www.google.com
2. Do a search for Mozilla.
3. Click on an unvisited link.
4. Once in the new web page, go back to the previous page. It will appear as unvisited.
5. If the link color shows as having been visited, refresh the page. It will revert color back to unvisited.
Actual Results:  
Unvisited link color remains unvisited (in this case, blue links remain blue after clicking through).

Expected Results:  
Unvisited link color should change color (in this case, links should turn from blue to purple after clicking through, and remain that way even after refreshing the page).

I will offer any additional information when asked. At this point, I do not know what is relevant or not.
(Reporter)

Comment 1

10 years ago
In addition to this, I have tried whatever common solutions that Google and the Mozilla Knowledge Database had to offer to help solve this problem, but to no avail.

I have tried using IE and Opera and they don't seem to have this problem either, so it is not a system problem.

Comment 2

10 years ago
First, make sure you don't have any overriding settings:
http://support.mozilla.com/en-US/kb/Options+window#Colors_Dialog

Next, you could try Firefox safe mode to see if it's caused by an extension or theme:
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes
(Reporter)

Comment 3

10 years ago
Just looked in the Colors Dialog and there's no overriding settings. Closed Firefox and opened it in safe mode while disabling all add-ons, extensions, and themes. Problem still persists.

Comment 4

10 years ago
Just to clarify: "Allow pages to choose their own colors, instead of my selections above" is checked in that options dialog?

Next thing to try is to check plugins:
http://support.mozilla.com/en-US/kb/Troubleshooting+plugins

And then try a new profile:
http://support.mozilla.com/en-US/kb/Managing+Profiles

That's almost guaranteed to work, unless you've somehow broken the install in a weird and subtle way. If it does fix it (and it's not a plugin via above) then there may be a preference set somewhere doing this.
Are you set to keep your history for at least one day?
(Reporter)

Comment 6

10 years ago
After struggling with this problem for several months and having it affect other aspects of Firefox - most notably those relating to bookmarks (could not add, could not search within the bookmark organizer, could not export or import) - I finally found the time to figure out how to get around it. Created a new profile, backed up the bookmark data from the old profile as well as copying the passwords and browsing history/cookies over to the new profile. Everything is working like a charm again.

In conclusion, it appears that the entire bookmark bug was just a corrupted places.sqlite file. As for the link bug that prompted this report, it may be another corrupted file that was subverted by creating a new profile.

Comment 7

10 years ago
Well then that means this is WFM. Glad it works.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.