3 MB increase in memory use Oct 27 - Nov 8, 2008

RESOLVED WONTFIX

Status

()

Core
JavaScript Engine
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: karlt, Unassigned)

Tracking

({footprint, regression})

Trunk
x86
Linux
footprint, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

We seem to be using about an extra 3 MB of memory.

The change in talos data is partially obscured by leaks that have been added and fixed.  This graph shows an increase on m-c with a t-m merge Oct 27 (bug 462826) and a drop when a leak was fixed with another t-m merge late Nov 7 / early Nov 8.  However the drop was not a great as the increase.

http://graphs.mozilla.org/graph.html#show=395024,395034,395054,787155,787156,787138&sel=1224667258,1226405644

It is hard to tell whether this is a leak or just an increase in footprint.
This graph compares m-c runs before the increase and after the drop:

http://graphs.mozilla.org/graph.html#type=series&show=2204043,2313925

Looking at graphs on t-m, it looks like 1 MB of the extra 3 MB resulted from changes between 2008-11-04 00:00 and 2008-11-06 12:00 (regexp?).  Note there is a leak fix before 2008-11-04 00:00, then another leak, then another leak fix.

http://graphs-stage.mozilla.org/graph.html#show=419436,419411,419456&sel=1225717900,1226064462

It seems that the remaining 2 MB is extra memory from the Oct 27 merge that has not been recovered.

Comment 1

9 years ago
FYI, the regexp engine uses a 1MB cache to store compiled regular expressions. It grows to 1MB max and then stays at 1MB. The JIT cache is 16MB max and never grows beyond that. We use a bunch of smaller malloc-ed data structures but we will move those into th code cache soon (instead of malloc/free). I am not claiming this explains the 2MB increase above. Just some information.
I think this bug can be closed now.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.