Maximize status does not store the screen

RESOLVED DUPLICATE of bug 264030

Status

()

Core
Widget
RESOLVED DUPLICATE of bug 264030
9 years ago
7 years ago

People

(Reporter: Daniel Friederich, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

It's a minor bug, I think. I mainly annoyed me because I was using occasionally a TV as second monitor without disabling it all the time, and Firefox suddenly started up on that screen all the time even when I closed it (maximized) on the primary screen the last time.
Details
Firefox properly opens restores the maximized state, but it does not store on which screen it was maximized. The screen apears to be the one Firefox was last closed non maximized instead.


Reproducible: Always

Steps to Reproduce:
1. Start Firefox. Non maximized. Move it to a secondary screen.
2. Close Firefox.
3. Start Firefox, move it to the primary screen. Maximize it.
4. Close Firefox.
5. Start Firefow. 


Actual Results:  
Firefox starts up on wrong, secondary screen.

Expected Results:  
Should startup on the screen it has been closed the last time.

The bug appears to be that the screen is not stored as part of the maximized state.

Usage of the primary/secondary screen in just a sample setup, exchanging the two shows the same wrong result.
Blocks: 236647
Component: General → Widget
Product: Firefox → Core
QA Contact: general → general
Duplicate of this bug: 468429
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → Trunk
Duplicate of this bug: 485718
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Duplicate of this bug: 497536

Comment 4

9 years ago
bug 264030 ?

workaround : 

- step 3 : on the new screen, resize the window a little bit.
- step 3.5 : maximize the screen

In my experience, it seems that resizing in step 3 saves the screen correctly, but maximizing doesn't. The maximized state is saved though. So if you both resize AND maximize, you can safe both the correct screen and the maximized state.
Duplicate of this bug: 500407
Duplicate of this bug: 501164
Duplicate of this bug: 526076
Flags: wanted1.9.2?

Updated

7 years ago
Duplicate of this bug: 440483

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264030
Flags: wanted1.9.2?
You need to log in before you can comment on or make changes to this bug.