If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

missing "drop indicator" line when dragging inside the main window's bookmarks menu

RESOLVED DUPLICATE of bug 419178

Status

SeaMonkey
Bookmarks & History
--
minor
RESOLVED DUPLICATE of bug 419178
9 years ago
8 years ago

People

(Reporter: Stefan A. Möller, Unassigned)

Tracking

Trunk
x86
Windows 2000
Bug Flags:
blocking-seamonkey2.0 -
blocking-seamonkey2.0b1 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081116 SeaMonkey/2.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081116 SeaMonkey/2.0a2pre

If you drag a bookmark directly into the main window's bookmarks menu, or re-order that menu's bookmarks via mouse-dragging, there is no moving line, which indicates where the dragged item will drop.

(You can see said line in the bookmarks manager, but not in the main window's bookmarks menu.)

Reproducible: Always
Whiteboard: DUPEME
Version: unspecified → Trunk

Comment 1

9 years ago
I can confirm it with   Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090129 SeaMonkey/2.0a3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2.0b1?

Comment 2

9 years ago
Neil any idea if we did regress this or if this has been there for a longer time?

Comment 3

9 years ago
This is because toolkit uses -moz-appearance for toolbarbuttons so that you can't alter the borders to provide drop feedback.

I don't know if or how Firefox provides drop feedback.

Comment 4

9 years ago
I think they use a drag-drop indicator similar to the way the tab drag&drop code.

Comment 5

8 years ago
Not blocking beta 1 on this but should probably release. Please renominate.
Flags: blocking-seamonkey2.0b1? → blocking-seamonkey2.0b1-

Updated

8 years ago
Flags: blocking-seamonkey2?

Comment 6

8 years ago
Not blocking 2.0, will consider patch though. Nominate for wanted 2.1 if you think appropriate. Is this a dupe of bug 419178?
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0-
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 419178
You need to log in before you can comment on or make changes to this bug.