If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Incorrect handling of missing <TD> elements & spans

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Péter Bajusz, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] See my figure and explanation)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
The following table is rendered incorrecly.
If you put <td></td> where the comment is, than it's OK.
I've checked M3 and 99-04-06 nightly.
-----------------
<table border>
  <tr>
    <td colspan=2>cell1</td>
    <td rowspan=2>cell2</td>
  <tr>
    <td rowspan=2>cell3</td>
    <!-- leaving out the last(!) cell in the row <td></td> -->
  <tr>
    <td colspan=2>cell2</td>
</table>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Target Milestone: M7
(Assignee)

Comment 1

19 years ago
Moving to M7.
(Assignee)

Comment 2

19 years ago
Moving to M9.
(Reporter)

Comment 3

19 years ago
Created attachment 501 [details]
Comparative testcase (HTML)
(Reporter)

Updated

19 years ago
Whiteboard: [TESTCASE] See my figure and explanation
(Reporter)

Comment 4

19 years ago
I created the attachment not to simplify the testcase, but to make it more
clear. I removed the html comment and created two tables the first one is the
one that is laid out incorrectly, the second one is there for reference.

The table structure looks like:
  +-----------+-----+
  |cell1      |cell2|
  |           |     |
  +-----+-----+     |
  |cell3| MID |     |
  |     | CELL|     |
  |     +-----+-----+
  |     |cell4      |
  |     |           |
  +-----+-----------+

Notice that while the "MID CELL" is not the last cell in it's row,
but in practice it is, because "cell2" is specified in the first row.
So the "MID CELL" can be left out of the table source.
That's what causing the error.

Looks like "cell4" is somehow put in the second row instead of the third.
(Reporter)

Comment 5

19 years ago
Created attachment 502 [details]
Comparative testcase - with my typing error (cell2->cell4) fixed...
(Reporter)

Comment 6

18 years ago
Looks much better with the 1999-07-31-08 build.
Cell 4 is a little bit up to the place it should be,
but it might be a different bug.
(Assignee)

Updated

18 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 7

18 years ago
Moving to m10
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
It now works in 1999-08-24-09-M10 apprunner (win98)
Marking WORKSFORME

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Verifying WORKSFORME per reporter's comments
You need to log in before you can comment on or make changes to this bug.