TM: lenient with unhelpful toString

RESOLVED DUPLICATE of bug 465460

Status

()

RESOLVED DUPLICATE of bug 465460
10 years ago
10 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
x86
Mac OS X
testcase
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Interpreter and JIT give different results:

b.js:
for each (e in [0, 1, {}]) { print('' + {toString:function()e}); }

./js ~/b.js
0
1
b.js:1: TypeError: can't convert ({toString:(function () e)}) to primitive type

./js -j ~/b.js
0
1
[object Object]

Comment 1

10 years ago
This is all Brendan.
(Reporter)

Updated

10 years ago
Blocks: 465479

Updated

10 years ago
Flags: blocking1.9.1+

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465460
You need to log in before you can comment on or make changes to this bug.